Can't acces to my "Firmware EEPROM configuration "

In repetier host, I just can't acces to my Eeprom config and since I can't change my Z stepp/mm, I can't print a single good piece....

It's been two month I try to fix this.... but I don't see how.


Pease...... help me !!!!

Comments

  • Has your firmware been compiled with eeprom support? Laso is your firmware eeprom supported. Host only supports Repetier-Firmware and Marlin here.
  • I don't even know what you are talking about, sorry

    Is there any procedure to follow to fix my problem ?

    Thanks for your support !
  • Maybe start with something more basic.  What printer are you using?  I assume it's running off an Arduino board of some type?
  • Reading firmware documentation would help. In case you are using Repetier-Firmware it is here:

  • No, this is not usefull. I arleady read it but thanks.

    I just want to know how I can enable my EEPROM setting on repetier ?
  • In th ehost it enables automatically as soon as it detects you are connected with printer running repetier-firmware.

    For Repetier-Firmware compile with EEPROM_MODE 1 or 2.

    If both are satisfied you should be able to select the eeprom menu and see the values. If you can open but do not see any values your firmware wa scompiled without eeprom support.
  • Hi, 
    I am having the same problem. The setting is greyed out.
    I have used EEPROM MODE 2 and 3 to no avail.
    I am using repetier 0.92.9 with mixing diamond hotend on ramps v1.4.
    Please tell me the solution to this problem. It is configured as you say and does not work.

    Thanks
  • @deussingularis and @lamarobot :
    Before I upload a new sketch I run the eeprom_clear sketch to wipe out my board then upload the new sketch to it.
    I run Arduin 1.65, but also have 1.06 and 1.69
    The eeprom_clear sketch is located in:
    File -> Examples -> EEPROM -> eeprom_clear
    I compile and load it to my board and it wipes out the existing program.
    Then I open my configuration.h file and verify/change the line in the 
    ######### misc. settings #########
    section to read 
    #define EEPROM_MODE 1 
    I turned on line numbers so in mine its line 377.
    Then I compile and upload it and in Repetier-Host I am able to access EEPROM configuration.

    I hope that helps. It works for me.Like Repetier stated earlier only Repetier and Marlin show up in that selection.
  • What does M115 return? We use the return string to detect firmware version.
  • Was his issue very resolved? I am having a similar issue. I can’t seem to make changes to EEPROM on my tarantula. I am using a Mac and I am able to connect to the printer, they to communicate but when I select EEPROM it comes out blank. I am trying to calibrate my extruder. Any suggestions on how to make the EEPROM appear on my machine?
  • Mac host only supports eeprom for repetier-firmware which is generic format. Marlin solution is quite complex and changes over time which is why it is not supported there. On mac you can use our Repetier-Server instead that also supports eeprom for marlin for known parameter.
  • With the latest build, I also get "EEPROM datasize error" when issue M500, M501, M504 on the RE-ARM board and no file eeprom.data was created on the SD card.

    --
    Lewis
Sign In or Register to comment.