[0.7.0 Linux] avrdude bug

When HEX firmware file upload is tried, error message appear that avrdude_bin do not exist.
ln -s avrdude avrdude_bin sloved issue as program avrdude is present not avrdude_bin.


  • But, even with this fix, upload hex still not doing the job.
    It now stops at "Uploading firmware binary ...". 
    Is there any way to see command line it execute, so I can debug further ?

    P.S. 2560 has been used.
  • edited December 2015
    Log file:
    Before 'ln' and after.

    2000-01-08 14:14:28: LUA job firmwareUploadJob#{"filename":"/var/lib/Repetier-Server/tmp/tmplua0.hex","lang":"en","slug":"Kossel800","verbose":1.0000000000000000}
    2000-01-08 14:14:28: Connection closed: Kossel800
    2000-01-08 14:14:28: /usr/local/Repetier-Server/modules/firmware/bin/avrdude: line 4: /usr/local/Repetier-Server/modules/firmware/bin/avrdude_bin: No such file or directory

    2000-01-08 14:14:30: Connection started:Kossel800
    2000-01-08 14:14:30: Reset printer Kossel800
    2000-01-08 14:14:30: error: Reading serial conection failed: Operation canceled. Closing connection.
    2000-01-08 14:14:30: Connection closed: Kossel800
    2000-01-08 14:14:33: Connection started:Kossel800
    2000-01-08 14:14:33: Reset printer Kossel800
    2000-01-08 14:16:52: LUA job firmwareUploadJob#{"filename":"/var/lib/Repetier-Server/tmp/tmplua1.hex","lang":"en","slug":"Kossel800","verbose":1.0000000000000000}
    2000-01-08 14:16:52: Connection closed: Kossel800
    2000-01-08 14:21:03: LUA job firmwareUploadJob#{"filename":"/var/lib/Repetier-Server/tmp/tmplua2.hex","lang":"en","slug":"Kossel800","verbose":1.0000000000000000}
    2000-01-08 14:22:17: LUA job firmwareUploadJob#{"filename":"/var/lib/Repetier-Server/tmp/tmplua3.hex","lang":"en","slug":"Kossel800","verbose":1.0000000000000000}
    2000-01-08 14:24:04: LUA job firmwareUploadJob#{"filename":"/var/lib/Repetier-Server/tmp/tmplua4.hex","lang":"en","slug":"Kossel800","verbose":1.0000000000000000}
    2000-01-08 14:26:23: Connection started:Kossel800
    2000-01-08 14:26:23: Reset printer Kossel800
  • Oh, my mistake, looks like this avrdude is part of https://github.com/arduino/arduino-flash-tools
    So no ln was required, just it need all files from that project.
    Question is, should be there x32 or x64 used, my guess x32.
Sign In or Register to comment.