Installation 1.1 kill my raspberry server


I have my license since 2019 and I have never had an update problem
Switched from 1.03 to 1.1 and my server no longer responds: 504 Gateway Time-out
how to restart the service? SSH works fine.



  • I will reinstall everything, I'm angry
    Next time i will wait
  • We already noticed and fixed this issue in version 1.1.2, which is also available now.
    You don't have to reinstall everything, a reboot of the system would be enough. After that you can install the fixed update.
  • I just took my 0.91.2 backup and updated via SSH.
    Always 504 Gateway Time-out
    nginx / 1.10.3

    SSH is working, the WEB interface is no longer working, the port is good.
  • As I said, please reboot your machine.
  • If it still does work, please post the ssh content where you tried the update, so we can see the error message/the problem.
  • edited August 2021
    As I said, please reboot your machine.
    3 times :smile:

    I post the SSH content, ok

  • login as: pi
    pi@'s password:
    Linux Repetier-Server 4.15.18-v7 #1 SMP Mon May 7 16:35:40 CST 2018 armv7l

    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.

    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Fri May 17 09:20:03 2019
    pi@Repetier-Server:~ $ sudo /usr/local/Repetier-Server/bin/RepetierInstaller /usr/local/Repetier-Server/etc/RepetierServer.xml                                                                                                               RepetierInstaller V1.1
    (C) 2015-2018 Hot-World GmbH & Co. KG
    Update info read ...
    Update file loaded and verified ...
    [1]+  Done                    xinit -- -nocursor 2> /dev/null > /dev/null
    pi@Repetier-Server:~ $
    pi@Repetier-Server:~ $ (Reading database ... 54205 files and directories currently installed.)
    Preparing to unpack .../Repetier-Server-1.1.2-Linux.deb ...
    Uninstall Repetier-Server
    Failed to open /dev/tty: No such device or address
    Removed /etc/systemd/system/
    Unpacking repetier-server (1.1.2) over (0.91.2) ...
    Setting up repetier-server (1.1.2) ...
    Install Repetier-Server
    Adding user repetierserver to group video
    Adding user repetierserver to group adm
    Failed to open /dev/tty: No such device or address
    Created symlink /etc/systemd/system/ → /lib/systemd/system/RepetierServer.service.
    Failed to open /dev/tty: No such device or address
    --------------------------------------- IMPORTANT ---------------------------------------
    You have ModemManager installed. This software automatically connects to new serial devices
    until it detects them not being a modem. This will interfere with printer connections and
    can cause communication errors during the first 20 seconds. To get rid of this you can
    uninstall the software with:
    sudo apt-get remove modemmanager
    If you need it for communication with mobile broadband modems make it ignore your serial ports:

    Processing triggers for systemd (232-25+deb9u11) ...

  • edited August 2021
    So update worked. Is now everything fine or still problems?

    You might want to deinstall modemmanager as it interferes with serial devices like printers.

  • I uninstalled modemmanager, reboot; still the same

    pi@Repetier-Server:~ $ sudo apt-get remove modemmanager
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libmbim-glib4 libmbim-proxy libqmi-glib5 libqmi-proxy
    Use 'sudo apt autoremove' to remove them.
    The following packages will be REMOVED:
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    After this operation, 2,333 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    (Reading database ... 54214 files and directories currently installed.)
    Removing modemmanager (1.6.4-1) ...
    Created symlink /run/systemd/system/ModemManager.service → /dev/null.
    Removed /run/systemd/system/ModemManager.service.
    Processing triggers for man-db ( ...
    Processing triggers for dbus (1.10.26-0+deb9u1) ...
    Processing triggers for hicolor-icon-theme (0.15-1) ...
  •  ps aux | grep RepetierServer
    repetie+  2439 99.5  1.0  19560 10312 ?        R<sl 11:36   1:07 /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml --daemon
    pi        2486  0.0  0.0   4368   524 pts/0    S+   11:37   0:00 grep --color=auto RepetierServer

  • I tried to access via a virtual machine under linux, same, no web interface. Reinstalled 0.91.2 ok but 1.1.2 does not work.
    I will download the whole image, I will have to reconfigure my two Prusa Mk3s

  • Installation and configuration complete. It only remains to test. Too bad all the same for this update which took me the whole day.

Sign In or Register to comment.