Linear Advances makes curved surfaces very rough

Hi, I recently activated the Linear Advance feature to improve the print quality on my Anet A8 with direct drive Extruder, Repetier Firmware 1.0.3. I tuned the Linear Advance Factor by printing and evaluating the Marlin K-factor Calibration Pattern. M233 Y110 got me the best results for my PLA filament. As expected, the prints come out more dimensionally accurate, no more blobs on edges and also the layer seam improved quite a bit.

However I just noticed, with LA activated, all curved surface on my prints come out very rough while flat surfaces look normal. The smaller the curvature, the rougher the surface. There's even some amount of overextrusion on rounded edges. It seems like LA causes some kind of noise in the movement of the extruder when printing curves, which manifests itself as a noisy and rough looking surface.

For example when printing a 3DBenchy with LA, the whole rounded surface of the bow looks a bit noisy and the rounded edge at the front of the bow looks really rough. Also the chimney, which is a curved feature, looks rough. When peering from the top over the edges of rounded corners like the ones from the roof, one can notice that the rounded corners stand out a bit, so are slightly overextruded. Another Benchy I printed with LA not activated came out beautifully shiny and glossy surfaces, even on rounded corners, and no overextrusion issues, just as expected.

What is going on here? Is this a bug?


  • I just modeled and printed a cone to further investigate, what's happening while printing curved lines. When grabbing the filament right before the extruder with my fingers I can feel a kind of sharp rattling, like tiny shocks that go through the filament. I'm certain, these unwanted harsh movements are what causes the poor surface quality on rounded features. But why is repetier doing this?
  • Further investigation: Because I suspected the Extruder Acceleration setting to somehow influence the behaviour of LA I tried to adjust the value to different settings. In the first try I adjusted it from 1000mm/s² to 10000mm/s². Actually I expected the extruder movements to be even more harsh and the print quality to be even worse but the opposite was the case. The surface looked a lot better, on some layers there were thick perimeters sticking out the cone a bit but overall there was an improvement visibile. Then I dialed the setting back to 100mm/s² just to see what happens. Bad surface quality again, but not much worse than with 1000mm/s². Then I set it to 100000mm/s². This gave me by far the best result. But still not quite as good as a cone with LA completely disabled.
  • The problem comes from rounding errors of step position in extruder. You need to upgrade to dev version where that problem already has been solved. In my test case with a cylinder it was a difference of day and night. Reason it happens more on curved surfaces is that a step more or less is more in % of line length having more impact.
  • Oh wow, thank you for your reply! :-) I just upgraded to the def version and the problem is gone.
Sign In or Register to comment.