Lost communication...

After many successful prints, the PC now can not communicate with the M2..? All settings were fine and communication was as it should be.  Now the Repetier host shows the printer to be unknown.  The COM port is correct and the baud rate... Also the printer shows the COM port to be connected.  Commands just sit there.  I tried to also run Pronterface, same outcome??  Connected another PC I had been using before and that communicates and prints fine.  So my thought is it must be the settings on PC1 and /or a software corruption issue?   Have reinstalled Repetier with no luck.  Reinstalled drivers, reset the printer PCB, no luck.  I have found many similar strings on-line about the same problem but no resolution yet.  Has anyone figured out why a printer working fine would suddenly lose communication and stop working? 


  • You could try a different usb port or a powered usb hub in case th eusb port has a problem with power load.

    If you have a FTDI driver for communication it could also be a clone and there were FTDI drivers not connecting to clones. As far as I know this was reverted due to too many complains.

    If host shows online it means it ha sconnected with a port but does not mean it understands communication - but as it works with a different pc I guess you have the same connection settings so it should if connected.
  • Strange. Two PCs set up identical (Both Toshiba's too!)  Both worked fine and then one now has a communication issue.  Tried different USB ports and have always used the same USB cable. I am wondering if there may be a corrupt file?  It can not be the printer because the other PC works.  My fear is if PC1 has this problem now, will PC2 have the same problem in the future.  I need to figure out what caused this. I hope others can help!
    Thank you!!
  • If your running Windows 8, I had the same problem. I uninstalled it using control panel, then cleaned it from the registry. Did a fresh install but UNCHECK the install server option. Works great now.
  • HI Jeff...thanks for the tip! I am running windows 7...but i wonder if the server option would cause this issue?? I will let you know..
  • Did you read server documentation?

    One special thing is that if you configured the printer, the server will always connect to printer and host can not connect any more (unless you deactivate the printer in server to free port).

    If you choose to run it over the server, you do not use the serial connection any more (cause it is blocked). You need to choose the server connector in printer settings, so you communicate through the server now. Only then do you get the advantages of both - the server and host.
Sign In or Register to comment.