On heat up of extruder 2 temp change is displayed at same time for both extruders ?

As in title.....If i start extruder number two i see temp change at same time for both extruders.Its just about whats displayed.....Printer works perfect.On independant menu under extruder tab all is displayed properly.Only on main display its going as i described it.....Can anyone help about what to edit in source files?


  • For some extruders this is even correct. If they share same heater block it would be ok. Please provide a response to M105 to see what firmware is saying. If temperatures are both at same set and read value you might have set the SHARED_EXTRUDER flag in firmware.
  • I dont have mixiing extruder but two independant extruders with independant heating blocks.I have checked what you said and there are three files where this flag is defined.....

    configuration.h here is :  

    extruder.h and - here its mentioned for mixing extruder enabled and its :
    #if NUM_EXTRUDER > 0
        extr = 0; // map any virtual extruder number to 0
    #endif // MIXING_EXTRUDER

    repetier.h :

    Should i change any of these?If i turn on both extruders to different temperatures at same time they work ok (manualy).....When i try to turn extruder2 manualy it is not showing as i reported but its showing all as it should.This happens only when i run g-code and use extruder number 2.I use Cura.

  • Settings are ok for different extruders.

    Don't know Cura to say when they show what. Can only say see M105 response to see what really is happening and eventually check if cura messes it up or if firmware is doing it wrong. That is what console/log is good fore. Seeing on which side the problem lies by analysing the communication.
  • Its not cura...I played a little with printer....If i go to extruder menu and select extruder 2 and then set its temp i have on main page on display temp change of extruder2 and extruder1 as same number.....while its not displayed that extruder1 is heating up (no animation).......so its just number mirror.If i set temp on extruder 2 without selecting it on extruder menu then all works good.So only when i go to "select extruder 2" and set temp i have this issue.Its definately firmware.
  • Please try repetier-server or repetier-host to check, these programs I know. Firmware is doing what it should for all so not sure what you do wrong here or cura does different then expected. Also I do not understand where you do what - on lcd of printer or in some cura menu.

    If you show a log of communication I can see if there is an error or not.
  • Its related to "select" option ...... soon i hit it , instantly temp of extruder2 is mirrored to extruder1 on main display tab....If i am printing somethng nothing is affected.....just shown value on main screen is same for extruder 1 as it is for extruder2.What should i change in source files to make this to work right?
  • what display are you talking about?  the lcd on the printer? which firmware version do you use?
  • If you show a log of communication I can see if there is an error or not.
  • Yes,LCD on the printer.12864 Display is what i have.I am using printer without PC.I will connect it to PC and post log here.

  • 13:35:31.002 : N134 M105 X0*105
    13:35:33.877 : N135 M105*32
    13:35:36.936 : N136 M105*35
    13:35:40.002 : N137 M105*34
    13:35:43.061 : N138 M105*45
    13:35:46.127 : N139 M105*44
    13:35:49.186 : N140 M105*34
    13:35:52.247 : N141 M105*35
    13:35:55.313 : N142 M105*32
    13:35:58.372 : N143 M105*33
    13:36:00.636 : N144 M105 X1*111
    13:36:01.438 : N145 M105*39
    13:36:04.498 : N146 M105*36
    13:36:07.566 : N147 M105*37
    13:36:10.625 : N148 M105*42
    13:36:13.691 : N149 M105*43
    13:36:16.750 : N150 M105*35
    13:36:19.809 : N151 M105*34
    13:36:22.876 : N152 M105*33
    13:36:25.937 : N153 M105*32
    13:36:29.003 : N154 M105*39
    13:36:32.062 : N155 M105*38
    13:36:35.128 : N156 M105*37
    13:36:38.187 : N157 M105*36
    13:36:41.253 : N158 M105*43
    13:36:44.314 : N159 M105*42
    13:36:47.373 : N160 M105*32
    13:36:50.439 : N161 M105*33
    13:36:53.498 : N162 M105*34
    13:36:56.565 : N163 M105*35
    13:36:59.634 : N164 M105*36
    13:37:02.685 : N165 M105*37

    It looks ok i think ?

  •  FIRMWARE_NAME:Repetier_0.92.9

  • Looks like missing the responses. They are filtered by host in log in view. You need to enable logging in host and check the log file which is complete. You also need to send the command to set the temperature so I see if it reacts correct not only some temperatures. I need to see enable one extruder and both show temperature is set something like the error you describe.

    Why are you starting with an old firmware version btw?
  • This firmware version was in printer when i bought it.So i didnt make new one but i decided to use this one and customize it a little.I received two firmwares.....one for two extruders and one for mixing extruder.I modified both to work with 3 extruders and i will probably modify them to use 5 extruders.At the moment i dont have mixing output but independant extruders and i use two.Only...... if i do "select" on LCD menu of my printer instantly temp2 si mirrored to temp1 value.All else is just fine.Which  benefits i can have if i make new firmware with latest version?
  • For the dev version you get better handling in combination with Repetier-Server, better advance handling, less bugs and many small improvements.

    Also I do not fully understand what you tell with errors, if you come from a shared extruder config make sure both extruders use different heater and sensor pins.
  • Imagine printer with 128x64 display.If you set temp on extruder1 for example to be 100deg. and it is dispplayed on the display ......and you then go to menu on LCD screen on the printer and under tab "extruder" click "select extruder2",without doing anything else temp of idle extruder2 is mirrored on extruder1 displayed temp value.So even extruder1 is on 100deg. it is displayed temp of extruder2.Thats all about issues i have.If i click on select extruder2 automaticaly temp of extruder2 is shown on main display for both extruders (its wrong showing only....all is working perfect) i have.
  • Ok, now I understood what you said, thanks. Also I never have seen it. Which language are you using? I ask because output depends on special chars in text and if a translation has wrong char e.g. current temperature instead of temp 1/ temp 2 it would show that way. I assume on repetier-host etc it shows the correct temperatures.
  • On host is all ok.I use english language.Even if i click select extruder2 and do something with it under extruder tab (menu page) both temperatures are shown properly.Only on main page temp1 is automaticaly replaced with temp2.I also tried to make and compile new firmware ......It wont compile properly.....Fan2 error......i used pins.h from old firmware and it compiled and reported endstop error (not defined) ......then i replaced endstop section from old config in new one....and it compiled.But i couldnt manage it to work properly even that way.Something is very wrong on both configuration tools versions on website.I tried both.In both compiled versions of new firmware i see same.....temp2 is not measured or same thing as i have on my printer......
  • Don't you use config tool? That would have updated the file automatically. But as soon as you start changing settings manually they are not copied to config tool:-(

    Still not sure which menu shows the wrong temperature as there are quite some pages showing multiple temperatures, but will check once I'm back to dev version on my printer.
  • I tried all.I started with my config upload and making new firmware - it cant compile - errors (FAN2 error pin) ......I made fresh new firmware with older version of config tool - it cant compile too (same error)......then i made new firmware with latest tool version......same thing.

    When i replaced pins.h file in all what i compiled with my older file then it compiled.So something is messed up with that in config tools (both versions available).With all respect,honestly, to me it looks that this is open source story,but without some money there is no chance to get something working.

    I bought printer and they sent me really working firmware.So i paied.Even then i tried to make custom firmware on Repetier and it didnt compile even then....that was one year a go.

    About temperatures and issue i have.I will try once more to explain so please read slowly (thank you in advance for doing that).

    There is one MAIN page when printer turns on.On it two temperatures of both extruders are displayed and under them hot bed temp is displayed.On that screen only i have wrong values related to what i explained.If i go to extruder menu and set temp for extruder n1 it is shown on MAIN page properly.If i go to extruder menu and under options i click on "select extruder2" automaticaly on MAIN page temp of extruder2 is shown for both extruders.This is i think very clear explanation.If you cant help its ok.If i have to pay for this let me know.
  • I do not expect paiments for solving bugs:-)

    What exactly is the error with FAN2? Note that not all boards define FAN2 so in these cases you have to select the correct digital pin number instead that you use.
  • You didnt comment anything about issue with temps whowing that i have?I know about pin defining for fan2 that didnt work.Board should be changed to 32 from 39.And ppins file should be replaced with older one i have.Then all works.
  • The main menu has the temperatures 2 times. Just had a similar config of 1.0.4 running which unfortunately has only the other screen.

    You mean the one with the lines and fan to the right. That is covered by
    #define UI_TEXT_MAINPAGE6_1_EN "\xa %e0/%E0\xb0 X:%x0"
    #endif // NUM_EXTRUDER
    #define UI_TEXT_MAINPAGE6_2_EN "\xa %e1/%E1\xb0 Y:%x1"

    in uilang.h for english.

    What is if you scroll to the temperature list covered by:

    #define UI_TEXT_PAGE_EXTRUDER1_EN "E1:%e0/%E0" cDEG "C" cARROW "%o0"
    #define UI_TEXT_PAGE_EXTRUDER2_EN "E2:%e1/%E1" cDEG "C" cARROW "%o1"

    As you see both use same outputs %e1 and %E1 and I have tested that the second which is the only I have is working correctly with that.

    You are using 1.0.3 or 1.0.4 right? Not that we compare here different version. Fixes are only made against dev version which is what i tested and is 1.0.4

    Do both screens have the same error?

    You also can have temperatures in the line but for these you define the codes in configuration.h so it depends on what you put in there.
  • edited April 2019
    #define UI_TEXT_PAGE_EXTRUDER_EN     cTEMP "%ec/%Ec" cDEG "C " cARROW "%oC"//" E:%ec/%Ec" cDEG "C" cARROW "%oC"
    #define UI_TEXT_PAGE_EXTRUDER1_EN     "E1:%e0/%E0" cDEG "C" cARROW "%o0"
    #define UI_TEXT_PAGE_EXTRUDER2_EN     "E2:%e1/%E1" cDEG "C" cARROW "%o1"
    #define UI_TEXT_PAGE_EXTRUDER3_EN     "E3:%e2/%E2" cDEG "C" cARROW "%o2"

    this is temperature lis t in my uilang.h

    and these are lines :

    #define UI_TEXT_MAINPAGE6_1_EN "\xa 1:%ec/%Ec\xb0 X:%x0"
    #define UI_TEXT_MAINPAGE6_1_EN "\xa %e0/%E0\xb0 X:%x0"
    #endif // NUM_EXTRUDER

    #define UI_TEXT_MAINPAGE6_2_EN "\xa 2:%e1/%E1\xb0 Y:%x1"
    #define UI_TEXT_MAINPAGE6_2_EN "\xe %eb/%Eb\xb0 Y:%x1"
    #define UI_TEXT_MAINPAGE6_2_EN "             Y:%x1"

    Is this ok?

    Only one screen has error.....main screen with fan speed on right side.

Sign In or Register to comment.