Error after upgrading 1.0.6 to 1.5

After installing V1.5, I get the error : <Slic3r> Cannot find specified configuration file C:\Users\Name\Appdata\Local\RepetierHost\slic3r.ini

The slic3r.ini file is located there, but there is second one in C:\Users\Name\AppData\Roaming\Slic3r

I configured the second path, but it did not help.


  • That is the slic3r config file generated by the host. Make sure the selected print/printer/filament profiles selected in the right slicer tab exist. As it does not exist the host had problems creating it so question is what is missing that it now fails.
  • The profiles exist in the ..Roaming.. directory. I re-installed 1.50, but it did not helped. After reinstallation of 1.06 it worked immediately without any configuration.

    Is there any logfile, I can see more details ?
  • All error messages catched should go to the log as well as the command used to call slic3r.

    Just retested slic3r with different settings in manager and it all worked.

    Does the C:\Users\Name\Appdata\Local\RepetierHost\slic3r.ini get created and changed? After every slice try it should get a new date. You said the file slic3r complains that does not exist is there, so it seems to be a problem of lsic3r reading that file.

    Could it be that your login has spaces or non ascii chars that cause problems? These file names always need special care especially on windows where utf-16 filenames are used. You could install Slic3r 1.1.7 in parallel and set it up in host. I guess that would also work with 1.5
  • Have now tested it my self with non ascii user name and that is in deed the problem. I have modified the host to use workdir as start directory so I could omit it in slic3r parameters. That seems to help slic3r enough to make it work again.
  • New host 1.5.1 contains the fix.
  • Today I tested 1.5.2 and it works! Thanks a lot.
Sign In or Register to comment.