Model Missing Layers When Slicing

Yesterday, the model had all of its layers when slicing it. The problem was that the filament was not stocking to teach layer (just a bit). I made some chances and now today only the first or just the two first layers get sliced and printed. I've tried Cura and it does the same thing.

This is with the Slic3r

This is with CuraEngine
These are my printer settings

Please, let me know how can I fix this.


  • This is what the model should look like,

  • Looks absolutely correct. Your disc in above image is maybe 3mm wide and 0.5mm height, so nothing else then 2 layers are required.

    Could it be that you need to scale the object to your expected size? You can set import dimensions which defaults to mm, but if you draw in inches you need to scale with factor 25.4 to get full size you expect.
  • Ah, that makes sense. Now that I changed the size, there's more layers which is what I wanted. Thank you! Do you know why the first layer never wants to stick to the bed? I already calibrate it so that the extruder nozzle touches the plate within the size of a paper. Most of the time I have to restart because the filament gets messy and spreads everywhere on the nozzle.
  • Depends not only on distance, also on bed material, filament material and temperature. I like to use a 0.3mm first layer height. Makes many things easier like measurement errors. But it still need a combo that sticks.

    There are many helps you can put on bed to improve. BuildTak for example helps most filaments stick. Sometimes even too good. Combined with heated bed it works great. Water soluble glue sticks or some kind of hair spray (or a special 3d printer adhesion spray if you want to be on save side) are also told to work.
  • Bed temp: 60
    Extruder temp: 210
    I have glass on top of the bed.
    I'm using 0.2mm. I tried 0.3mm but still does the same.
  • This is my problem now. Look at the top layer, I'm not sure why is it doing that. I'm new to 3D printing, not that new. I   have done some printing before, but only a couple.
  • Extruder is not calibrated correctly. Has nothing to do with sticking to bed problems. This looks more like under extrusion. Make sure flow multiplier is set to 100% and then heat up extruder hanging with space to bed. Mark a point at the filament with distance > 50mm to where it goes inside extruder and measure distance. Then send
    G92 E0
    G1 E50 F60
    and measure distance again. Difference must be close to 50mm. I think you will get less so change steps per mm in eeprom for extruder to
    newValue = oldValue * 50 / measuredDifference

    Then repeat. After that extrudion is normalized as slicers expect it. Also make sure extrusion multiplier in slicer is set correctly. For PLA 0.85 - 0.90 (=85-90%) is a typical value. Then it should look much better.
Sign In or Register to comment.