Arduino wont update k200 firmware

I have tried to load several variations of the Repetier firmware into Arduino for uploading to my k200.  I get the following error.  I uninstalled Arduino IDE and reinstalled it with no change.  What's wrong?

Arduino: 1.8.8 (Windows Store (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"
sketch\Eeprom.cpp: In function 'initalizeUncached':
sketch\Eeprom.cpp:522:1: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <>; for instructions.
lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status
compilation terminated.
c:/program files/windowsapps/arduinollc.arduinoide_1.8.19.0_x86__mdqgnx93n4wtt/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed
collect2.exe: error: ld returned 1 exit status
exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.
This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


  • Ok, that is bad if compiler crashes. You could try changing some features also you do not need them, e.g. G2/G3 which is not used normally. That may lead compiler to a different content making enough difference to not crash.

    Alternatively install a older version (all 1.8.x should work) with a different gcc version included.

    You can also go to Eeprom.cpp line 522 and reorder the eprSetFloat lines. Order does not matter here. This is all to make compiler use a different compile path preventing compiler error. The file it self is ok.
  • Thanks, I had the same problem with version 1.0.3. Turning off G2/G3 fixed it.
Sign In or Register to comment.