DualX: extruder only moves in one direction (offset)

I have a cartesian independent dualX that shows "weird" behaviour as already reported here
At some point during the print, the extruders only move towards their parking position. I have tried with LAZY_DUAL_X_AXIS enabled and disabled and it happens anyway. Suspecting the drivers (RAPS128 on RADDS), I added a DIRECTION_DELAY, but that did not help either. Single extruder print does work as expected, so it is safe to say that is related to dualX mechanics.

I then stumbled upon @Braccoz improvements (aka hidden feature) and tried to go along this path. But same results again. Here is my configuration.h (as .jpg)

Unfortunately, I failed to manually reproduce the behaviour reliably. But printing a dual color benchy constantly failed at the same height / layer. At some point during the print, both heads will only move towards their parking position - e.g. left extruder only moves left, right extruder only right. I suspect that the offsets increment over time and when they reach a certain threshold, they display the errant behaviour.

Will post back if I find a reliable way to reproduce the behaviour - apart from the benchy.


  • Forgot to mention: Tested with current dev from github
  • Update:
    Despite some randomness (which would make me belief it's a hardware issue), dry-running the same gcode about a dozen times, at least some symptoms show a pattern (which suggests a firmware issue). The object is a simple bar running along x-axis.
    These are my observations:
    - Left extruder always fails first, right extruder fails immediately after change of extruder
    - Occurs at random layer heights
    - Extruder hits a dead zone where it is not allowed to move into: At some point and right before entering the dead zone, EXT0 is delayed for a second - pseudo-executing the next move -  then continues back to home position. 
    - None of the extruders will recover to correct mode of operation: After hitting dead zone, it will continue to skip the moves into it.

    Check out video. The first run is fine, 2nd and 3rd show the split-second stop (nope, it's not a glitch....sorry for the lousy quality tho  :# )

    It is important that endstops are never touched during print. If you have rotated bed it might hit a endstop at some height preventing move in opposite direction. Just an idea, but it would explain it at least and I have no better idea what is happening that matches better.
  • You are my master :) Would have never crossed my mind to check endstops....
    Tried to increase ENDSTOP_X_BACK_ON_HOME as alternative but for the sake of reliability, your suggestion is more bullet-proof. Thanks a lot, case closed.
    PS: Still looking forward to test a first beta of V2
  • Then try it. On github there is even a sample config for dual x printer. Also waiting for the dual x printer to arrive so I can continue testing, but as far as I know it is working good. Vendor is also planning to use V2 for the printer.
Sign In or Register to comment.