Watchdog and X Axis control

I am just getting started.  Searched discussions but can't find these topics yet. 

First issue, I have no printer yet, only the electronics and trying to establish motor control through the Rep Host. The firmware configurator web page does not seem to allow download unless the watchdog is enabled.  I have no extruder, and establishing motor control is difficult to debug with the numerous watchdog messages; I'd like to turn this off but cannot get the firmware to download without watchdog checked.

Second issue: X axis movement seems inconsistent. I assume this has to do with potentiometer adjustments on the A4988, but don't know for sure that I'm sending the correct commands. If I use manual or the Rep-Host X-movement joystick clicks, how can I be sure a pure X-movement command is being sent to the motor (ie, bypassing the "jerk" and other calculations)?

Thanks for your help!


  • You can download with watchdog disabled. That is a warning so you know what you are doing. buttons still work. But what do you mean with "numerous watchdog messages"? 

    These manual controls always only move one axis. If coordinates are red it always work if black (which they become after homing) you can only move within your printers coordinates or no command gets send. Jerk can not bypassed - it is always present and must even be there for the firmware to work correct, so firmware enforces a minimum jerk when necessary.

    If you think your poti is set wrong try moving motor by hand. they are fairly strong so you should need quite some force to overcome motor power. Normally you hear if the motor is loosing steps due to too high jerk/acceleration/speed.
  • Thank you for the reply.  I may have solved the motor movement issue by changing the wiring on the motor.  The two coils of the motor may have been cross-wired.  Now, I see that jerk matters significantly, especially if you're doing something like extruding, or carving (eg, CNC router).

    Here is an example of the conversation the firmware and Host are having.  Recall that I have no extruder, unchecked in the configurator before downloading.

    20:29:15.642 : N86 M105 *57
    20:29:15.644 : ok 86
    20:29:15.968 : N87 G1 X25 F4800 *34
    20:29:15.971 : ok 87
    20:29:18.701 : N88 M105 *55
    20:29:18.703 : ok 88
    20:29:21.765 : N89 M105 *54
    20:29:21.800 : ok 89
    20:29:24.830 : N90 M105 *62
    20:29:24.897 : ok 90
    20:29:27.887 : N91 M105 *63
    20:29:27.891 : ok 91
    20:29:30.952 : N92 M105 *60
    20:29:30.954 : ok 92
    20:29:34.012 : N93 M105 *61
    20:29:34.014 : ok 93
    20:29:37.077 : N94 M105 *58
    20:29:37.082 : ok 94
    20:29:40.137 : N95 M105 *59
    20:29:40.138 : ok 95
    20:29:43.204 : N96 M105 *56
    20:29:43.206 : ok 96
    20:29:46.262 : N97 M105 *57
    20:29:46.266 : ok 97

  • The M105 is temperature polling and comes from the host. In Repetier-Host you can disable it in printer settings.
  • Thank you.  Most helpful!
Sign In or Register to comment.