1.02 configuration tool unexpected moving core x y

I write again about this situation because I don't find a real solution for it 
I build a core xy and i intend to use repetier firmware on my ramps 1.4
my problem is after uploading the firmware my printer is not moving right

if i try moving on x +, my printer go on x
if i try moving on x -, my printer not moving
if i try moving on y +, my printer is moving on  - x - y
if i try moving on y -, my printer not moving
somebody tell me something like i don't provide library for 1.8.x for endstop - which i don't understand

I have arduino 1.8.5 updated all libraries
I don't find any setting for endstop  closed by core xy functionality
iI dont find any setting on steppers motor closed to core xy
the only setting i found is on General where I tell is an core xy
I upload my configuration which is working on old arduino 


  • this is my configuration.h

    thank you
  • sz3bbylA said:
    this is my configuration.h

    thank you

  • First run M119 and see if all endstops are low. If not moves may not happen. Normally if + direction works the minus is also working, but minus requires endstop to be low. Minus also requires a positive position and at start you are at 0,0 so form start position negative moves are also impossible. See M114 return values for current position.

    I can not make a list/doc that shows you which system is right. You have to select between drive system 1/2 and also invert direction motor x/y. There is some logic in it and if you know how motors should move it is easy to find the right combination with a few tries. With many motor connectors you can rotate them 180° that is the same as inverting direction but much faster for testing then uploading. So you only need drive system 1/2 as upload and experiment with direction once endstops are set correct.
  • unfortunately when i write firmware  some month ago from an raspberry pi with an old arduino software work perfect and was no problem with endstop's 
    i tried after to write the same firmware with arduino 1.8.5 and happend this but I quit that and i plug raspbery  because i want o print some parts
    now again I have some time and I want to port configuration to 1.0.2 and write with arduino 1.8.5
    i ported like i copied parameter with parameter to new configuration also I tried to load configuration.h in 1.0.2 
    Happens the same think
    my printer corexy have motors in the back and endstop  only in front
    I would like to upload my configuration here  but I tried 2 timed without success (one time like normal configuration and second like zip file)

    i read a little bit about corexy and repetier firmware and i understand can mix a config like deltaprinter but with something changed and this is called faster corexy but i don't understand to much 

    in my online configuration look like is set to corexy but motors control is taken wrong and i got this abnormal moving

    my config is uploaded on 

    thank you so much in advance 

Sign In or Register to comment.