Autobedlevel and Z homing setup with Inductive Proximity NPN

I have a DIY Prusa i3.
Everything was ok without proximity sensor.
Then I bought a LJ12A3-4-Z/BX Inductive Proximity Sensor Detection Switch NPN DC6-36V 4mm

I tried to follow the instructions here:
First I manually test the probe: OK
Then I start calibration as described in Calibrating Z-Probe.
I'm using a 1mm metal block
G30 P0 - The extruder moves down until the probe activate on the metal block. EX: Z-Probe: 9.867 X:10.00 Y:20.00
Then: M114 - The Z height is set as Zold EX: X:10.00 Y:20.00 Z:10.000
Then I start to manually go down but it stops when Z=0 so I can't go down to touch the nozzle on the metal block.

Can someone please try to find the problem?


  • - G1  - Coordinated Movement X Y Z E, S1 disables boundary check, S0 enables it

    So disable boundary check and you can go below 0 with G1.

  • Thanks for your reply.
    I've tried with no success.
    The minimum Z height I can go is -0.01
  • Do you have ALWAYS_CHECK_ENDSTOPS 1? In that case the triggering z probe might prevent the move as well.

    Try different solution in that case. Go down to bed, check height then test when nozzle would hit the metal block. That is the official solution anyway to exactly prevent such a problem. Works if metal block is higher then z probe distance.
  • Just a idea but wouldn't setting 'Z min pos' to say, -5 in eeprom allow Z to go negative.
  • Not really. You get the same problem at -5 instead just with other coordinates at  same point. It is the endstop/z probe making the problem here.
    I've changed to 0 and upload the firmware
    Tried but didn't worked.
    Then I've changed EEPROM_MODE to 2 to force overwrite settings.
    Tried again but didn't work :(
    Maximum I can go is -0.01

    Here is a link with mi Configuration:

  • I've tried to change some settings without success.
    As described on your instructions I've changed this:

    #define Z_PROBE_ON_HIGH true
    (Had to change to 0 again because when I make G30 P0 it starts to go up and then gives error)
    #define Z_PROBE_HEIGHT 39.91
    #define Z_PROBE_BED_DISTANCE 30.0

    Do I need to enable Autolevel?
    My printer is like this one:
    My extruder and probe is this one:
    I don't have Z Limit switch on top or bottom. The Prob is connected on Z-Min pin.

  • Another interesting thing... when I send G30 the extruder goes up and then I have the error like in the attachment.
    Is it normal to go UP? Shouldn't be Down?

  • I've found that if I press the Z button it will not go more than -0.01
    but if I send a G1 Z-(value) it will go the that negative value!!!
    Shouldn't be the same?!

Sign In or Register to comment.