Homing issue on custom Delta build


I have a really strange behavior, both on the latest 9.2 and also 9.1.8

When hitting the home button, X axis gos up, hits the end stop and all works well.
But Y and Z axis act randomly.
sometimes they also goes up all the way, and sometimes they stop before getting to the end stop.

Y and Z have the same strange problem, but each is independent.


I wanted to attach the config file but i cant.
also, pasting the file here givs an error that the post is to long....


  • P.S 2

    I am an electrical engineer, - not a complet noob :-)

    I know my stuff... all endstops are connected, working and tested.

    also, it worked fine with marlin. i changed to repetier because i want to use the bed leveling...
  • Here is a video shwing the problem

  • It is crosstalk to y and z endstops normally cause by the motors running.  Would really like to know how Marlin detects crosstalk. 
  • How should I solve this cross talk do you suggest?
  • Bay the way, jogging on X, Y and Z all works perfectly fine.
    So maybe it is not crosstalk between engines?
    Maybe crosstalk between, end stops?

  • I added 2.2K resistors on all end stops.
    Problem still exiexists.
  • Normally drilling the cables works.
  • Yes, problem solved :-)
Sign In or Register to comment.