Raspberry Pi B+ with Raspbian December 2014

Hi, I have been working on trying to set up the server on my Raspberry Pi.  I purchased the Pi just for this task and am very new to Linux (this is my first experience with it).  I have my OS installed, have the server installed, and have my WiFi adapter installed.  I have been trying to access the server from the Pi in Raspbian  using localhost:3344 in the browser window and it tells me that it cannot connect to localhost.  I have been testing and setting this up without my 3D printer installed.  Does the printer need to be attached for it to be able to connect to the server? 




  • No there is no need to connect a printer, also some menus and windows only appear when a printer is configured and connected.

    You should NOT connect to the server in a browser running the server. I think the pi is not fast enough and also may lack ram for all this. After all the frontend is a quite big and also needs a fast browser. That is also not the intension of the server. It is made to run the server on the pi and we are working on simple frontend for building touschscreens which use less resources so it can run on the pi directly. Get the ip (ip addr) and connect form your pc browser to it using http:<ip>:3344

    Also make sure server is running

    ps aux | grep tier

    should show it running. When in doubt

    /etc/init.d/RepetierServer restart

    should restart it.
  • Ok, I have tried those to see if it is running and it looks like it may not be running.  Doing the first test, it showed:

    pi    2015  0.0 0.1  3548   808 pts/0   S+  14:36  0:00 grep  --color=au

    to tier

    that is plus or minus some spaces, of course.

    trying to restart the server, it said it failed

    "unable to set gid to 20 (Operation not permitted)"


    I have installed the "armel" version.  Was that the correct version for the pi b+?  I think once I get this running, I may upgrade to the new, faster pi 2.

  • So I realized that my keyboard layout was not correct.  Some of the symbols were not working properly on the keyboard "|" for instance.  I went into the keyboard settings and realized it was set as "gb" and set it to 'us".  After that, I restarted my Pi and everything worked.  Now I just need to set up my printer for the server.  Thanks for your help.
  • There is new Pi 2 
    4 cores and 1GB Ram 
    Think that can carry RH buch better then Pi B+
Sign In or Register to comment.