Slic3r freezing windows 10

edited December 2016 in Windows

Repetier host is freezing my laptop when i use Slic3r but not with all prints, the tablet stand gives no problems. When i slice a print it starts slicing and its finishing slicing(i think) In the log i see how much filament is gonna be used and the button "send to server" appears but the same moment the windows is freezing. The computer is not responding and must be forced to power down. When i use Cura with the same print it will finish slicing and i can send it to the server.

System: i5 2550M CPU@ 2.5GHz x64 with 4Gb RAM running windows 10

Tried: Reinstalling (multiple times, with and without admin rights) Repetier Host after uninstall and registry clean, updating Slic3r, renaming registry /HKCU/Software/Repetier from this post and ran sfc /scannow not reporting problems.

Slicing the same prints at different computers(windows 10) with repetier host is not giving any problems.

Any ideas?


  • Please have a look at the taskmanager and free memory. The host computes the graphics in memory and later stores them in video memory if allowed. That uses a lot of memory depending on filament quality you set. From oyur description it manages to load the gcode but when finishing the rendering in hangs. In that case slicing small objects should be no problem.
  • Well, it is definitely a memory problem but it takes more than 50% of the total memory.
    During the slicing it takes around 50MB, total with FF and Comodo running thats 39% total memory usage. The last thing i can read before freezing is repetier is using 2.500MB isn't that a bit much? And why does the rendering go well when using Cura? I sliced the same object with Cura and it takes about 100MB extra when rendering the image.
  • Compare your slicer settings. I guess the slic3r gcode has much more lines. Maybe smaller layer height or more infill, other infill pattern. Since every line takes maybe 200 bytes that can easily sum up to a good amount of MB. One of the reasons the server does never read complete file into ram. So it can print any gcode even on raspberry pi.
  • Hmmm, did that check, with approximately the same settings. Results;

    Cura(working) 114350 lines
    Slic3r (freezing laptop) 95166 lines
    Slic3r (Other. PC) 129464 lines

    So i think its not about the ammount of lines. Cura generates more lines.

    How do i remove host and the slicers so really nothing stays behind? I noticed some of my settings are restored after reinstall

    Or do you have a better idea?
  • So if I understand you correctly Cura with 114350 lines uses 100MB in host while the 95166 lines from Slic3r utilize 2500MB in host? That would be quite drastic and a bad sign. Would that slic3r file also behave like that on the other pc? If yes it must contain something that confuses the host and I'd like to get a copy of that file so I can analyse what goes wrong. If it works on the other pc it must be some file wrong.

    Visualization only depends on 3d settings stored in registry (HKCU/Software/RepetierHost) and has nothing to do with any slicer configs (Cura in work directory subfolder, slic3r wherever you wanted it normally in home/AppData/Roaming/Slic3r).

    You could try reinstalling host in case a binary got corrupted somehow, but then I would expect cura gcode to behave the same.
  • edited December 2016
    Yep, thats exactly what i mean.

    Reproduced it again this morning, what i did;

    Checked the settings again and found a wrong setting, 0.2mm layer height with 150% first layer wont work with a 0.4mm nozzle. So made it .35mm. Tried again.....still freezing.

    Took another (old) laptop with host on it, connected it to server, pulled the settings and imported the config.ini from the freezing laptop. So to me it looks like i have 2 identical host installations?
    Sliced the same object with the same settings on a old laptop, took a bit longer to slice and rendered the image correctly!

    I will send you the STL and my config by mail, let me know if you need more
  • config.ini gets always overwritten with each slice so that does not say anything. The only real test is loading the generated gcode from freezing computer on the non freezing as I said. If that then also fails it is the gcode file I need.
  • Well, the problem is i couldn't save the gcode because host is not responding after the slicing. So i diabled filament visualisation and saved the gcode. Imported this to another laptop and it showed me the preview. After this i enabled filament visualisation in the freezing laptop and imported it, showing me a preview without any problems....?

  • Well, I still don't know what the problem was. But it looks like the Windows Creators update solved the problem.
  • Good to hear.
  • I have had a similar problem at exactly the same spot. The problem is actually with the display driver (I think) the solution is when one goes to: Config|3D visualization|Filament TAB and then set Filament Visualization to "simple" it solves this error permanently. It is rather sad though since sometimes I would have liked to see the actual printing movement and in this mode its not possable. Maybe the cleaver guys can figure out whats wrong with the function...
  • I think the visualization is fine. Just full video memory or generic Microsoft OpenGL driver cause it to crash. What do you see in log at startup for the driver? How much memory does your graphic card have?
Sign In or Register to comment.