Error compiling Repetier-Firmware 0.92.7 (twi.c)

edited December 2015 in Questions & Answers

I generated a configuration.h file using the online configuration tool and downloaded the entire firmware. When loading it on Arduino 1.6.7 (both portable and instalable versions) the program gives the following error when verifying the code:

Arduino:1.6.7 (Windows 10), Placa:"Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

sketch\libraries\twi.c:1:17: fatal error: twi.c: No such file or directory

 #include <twi.c>


compilation terminated.

exit status 1
Compilation Error

I've found twi.c in the "libraries" subfolder under repetier firmware and tried copying it to the arduino/libraries folder. I also tried using the "include zip or folder library" option that arduino has but that didn't work. I don't know what I'm doing wrong, any help on this?



  • I have analysed the problem and it's Arduino doing something stupid. Since 1.6.7 it compiles all subfolders also it does not show them as project files. These files never were meant to be compiled by arduino - they belonged to a different ide.

    I have now removed the extra files so Arduino will also compile with version 1.6.7. An other stupidity is that existing copied folders in temporary build directory  do not get deleted so you need to restart Arduino IDE to compile without the removed files.

    Also make sure to not unpack in same directory sicne you have then still the extra folders.

  • Okay, I will delete my current firmware folders, download the revised firmware and try again.

    Thank you very much, I will report the result asap :)
  • Hi again. The fix works like a charm so the problem is solved. Thanks :)
  • hi i have save problem can you please send link for firmware thank you
  • Latest 0.92.8 but you must restart arduino ide!

  • Can you advise which specific folder(s) I should delete before downloading the new version? I have the same problem. Thanks. I am running Arduino 1.6.8. Should I delete it and reinstall?
  • The repetier folder containing the .ino file should have no subfolders (which were ignored in previous releases). Arduino copies them to it's build directory where you need to delete them as well (HOME/AppData/build.....). You find the right one normally from looking at the compile commands.

Sign In or Register to comment.