Choppy printing Delta

I have delta with Mega/Ramps electronics. When I print cylindrical object I get 
choppy print movements every second or so.
my #define DELTA_SEGMENTS_PER_SECOND_PRINT 
is set to 120
I switched from MArlin  to get beter performance, but this is even vorse.
Print speed is 35.
Any suggestions ?
Mario

Comments

  • To get a fluent print buffer must be kept full and model/gcode must not consist of too small lines. You should optimize subsegments and buffer to use the ram such that you have only 900 bytes free ram with at least 16 buffered moves. Better is a RADDS board with 96kb ram as this is faster and can cache more move. If it can not cache enough to go to full speed it will change speed as well. Here a low acceleration might be bad as it increases the required distance. Hope one of these is your problem.
  • thank you, but I already tried to lower delta segments, unfortunatelly I cant increase cache
    size from 16, because of memory limitations. At the moment I dont have Due and Radds Combination.
    Stuttering is the most obvious if I load Gcode generated in Simlify3d, but only in Skirt portion at the begining of print.
    After Skirt being lay down, movement seems almost normal.

    I dont know why only Skirt produces such Stutter ?
    I even disabled Display completely but Skirt printing remains interruped almost every 10 mm

    I have Quad Stepping enabled as this was a default in Configurator, should I turn it of ?
  • You can not get speeds where quad stepping gets used, so on or off makes no difference.

    What software do you use to send the gcode? Please try repetier-server without Ping-Pong mode. That will use the fastest possible communication over usb, just in case it is the number of commands send over usb causing the problem. As I said this happens if buffer gets too low which can be a result of the sender being too slow. And repetier-server uses binary protocol for compression and sends several commands at once which can drastically improve throughput.
  • edited October 12
    I printed from SD Card, no computer connected
  • Ok, so you already have a good rate of commands.

    Have you tried printing a simple cube? Just to rule out one of the reasons I told you - models with many small segments.
  • Today I printed a Cube 20x20x20 mm with a Skirt and as you suggested
    printing is smooth.
  • Great, so it is clear where it comes from. What is your acceleration? As I said with higher acceleration it is also possible to print smaller segments. But main problem will stay models with such a high resolution that it creates to many small segments exceeding the buffer capacity so it will slow down and accelerate.
  • edited October 13
    my acceleration settings:

    #define DOUBLE_STEP_DELAY 0 // time in microseconds

    #define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_X 1000

    #define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Y 1000

    #define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Z 1000

    #define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_X 2000 

    #define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Y 2000

    #define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Z 2000

    #define INTERPOLATE_ACCELERATION_WITH_Z 0

    #define ACCELERATION_FACTOR_TOP 100

    #define MAX_JERK 20

    #define MAX_ZJERK 20

    #define PRINTLINE_CACHE_SIZE 16

    #define MOVE_CACHE_LOW 10


    print speed was 35.
    Should I increase acceleration ?
  • At least I would try increasing acceleration to 2000 and maybe even MAX_JERK to 30 or 40 if your printer can handle this. Since deltas normally have light heads due to bowden setup this is normally no problem. But both changes reduce required buffer for full speed and you get into trouble if you can not reach 35 due to small segments.
Sign In or Register to comment.