No webcam stream, only static image

In Repetier server (version 0.86.2, but have had this problem since first 0.86 release) I can only see the static webcam image, not the stream.

If I go to Printer Settings > Webcam I see both static image AND the stream.
Browsing to http://IP:8080/stream.html I see the stream too.

Board is RPi 3B, and camera is Logitech c170

Any solution to this?

Comments

  • What webcam software do you use?
    You have to watch out with the url - that it works in browser does not always mean it is the url for the mjpg stream. It could also be a html page containing the stream. And the stream must have mjpg format and not an other video format - it will only work on mjpg streams. For the right url right click on the stream and open image in new url. That should give you right url. If you open debug tools of the browser and reload you should see in network the stream and can see the content type. Main type is multipart/x-mixed-replace with subframes of type image/jpeg.
  • Dynamic Image URL: http://localhost:8080/?action=stream
    Static Image URL: http://localhost:8080/?action=snapshot

    As written, under Printer Settings > WebCam I can see the stream.

    Actual URL (right click missing stream, open in new pane): http://IP:3344/printer/cammjpg/Anet_A8_3D_Printer?rand=EqObiEwONZ&sess=UKE@5WdKbPFZ3xTXFiNK#Gv1jhKW98$d

  • Yes, that looks familiar for mjpg streamer. So good it is now working with right url.
  • Only it isn't. Only the preview under settings is working.
  • What do you see? The image that no webcam is available or a broken image? Which browser/os do you use? Normally there are no problems with mjpg_streamer which you are using (right?).
  • I have tried Edge, IE and Chrome - all with same result.

    I see the "webcam" with a red ring and a line over.

    When I access the stream directly (http://IP:8080/?action=stream) it Works like a charm, but http://IP:3344/printer/cammjpg/Anet_A8_3D_Printer?rand=EqObiEwONZ&sess=UKE@5WdKbPFZ3xTXFiNK#Gv1jhKW98$d is not working.





  • That image means the server does not succeed in reading a mjpg stream from the url you provided.

    The link you show contains a session and that changes every restart, but of course on reload it will set it correctly.

    You could try if
    http://127.0.0.1:8080/?action=stream
    works better. Also localhost is the same as 127.0.0.1 but needs resolving.
  • It was 127.0.0.1 at default - not working, hence the change to localhost (just to test if that was better event thou it resolves to 127.0.0.1)
  • What resolution and framerate do you have selected? With 640x480 and 20 FPS it is working fine for me. And you said in config you can see the video, so that seems also configured correctly. And I assume in "Webcam Connection" you have selected "JPG + MJPG Stream"? Don't really think logitech 190 to 525 model makes a big difference here.
  • I see I run same settings as you. Tried with both 20 and 25FPS - no change :(
  • Just to understand for you. Normal webcam usage gets proxied through the server so you can access it from everywhere where you can access the server. That part seems to have problems to understand the response.

    Are you using the repetier-server image with mjpg_streamer or do you have compiled you own mjpg_streamer? In latter case, which source did you use? Maybe it is now sending in a slightly different format that causes the proxy to fail.
  • I'm using the Repetier-Server image for my RPi.
  • Thats bad since that is what is working and best tested by me.

    Does /var/lib/RepetierServer/log/server.log
    contain any hints. Except for normal termination the cam reader logs the error reason.
  • Nope.Last log entry is 13th august 2017.

  • Did you reboot after all the config changes? Not that it is just not trying any more?
    Remmeber an other guy with webcam problems and he said after a restart all problems were gone.

  • How is the default nginx config (/etc/nginx/sites-available/default) supposed to look?
    If you say this is the one proxying, then I have a suspicion that this might be the faulty bit.

  • No it is not nginx. It is the server doing the proxy from webcam and replacing it with no webcam picture.

    Did you try the reboot? If 13. august is last entry in log  you have not rebootet since then, so give it a chance.
  • It's powered off every night, and prints every day.
  • "Nope.Last log entry is 13th august 2017."
    After each reboot you get new entries here, so why only 13th august? Is there another log file with newer content?
  • No, there is no other logfiles in the directory.
    And I have no ide why it haven't logged anything since.

  • Is the disk full? That might cause other problems as well.
  • Unfortunately not the answer either.

    pi@CNC:~ $ sudo df -h
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/root        30G  6.1G   22G  22% /
    devtmpfs        429M     0  429M   0% /dev
    tmpfs           433M     0  433M   0% /dev/shm
    tmpfs           433M   45M  389M  11% /run
    tmpfs           5.0M  4.0K  5.0M   1% /run/lock
    tmpfs           433M     0  433M   0% /sys/fs/cgroup
    /dev/mmcblk0p1   63M   22M   42M  35% /boot
    tmpfs            87M     0   87M   0% /run/user/1000





  • I'm running out of ideas. Yesterday I had a user also with C170 and he had no problems with the webcam, so that should work. Have you tried reloading website with Strg pressed to force a full reload including cached files? Maybe browser cached it, also we add a random string to prevent caching.

    The other question would be why /var/lib/RepetierServer/log/server.log does not get updated. Could you delete the file and reboot to see if it gets recreated. Your disk ha splenty of free space so that is not the problem. One thing might be a corrupt file system on sd card. Have seen this happening and causing strange results. Do you always shutdown the pi (good) or just unplug power (bad)?
Sign In or Register to comment.