Z Controls not working

Hi, I am currently using the Repetier Host V2.0.1 and I just set up everything almost perfectly. Minus the part that the Z control isn't working. Homing works fine though. 

The type of printer is a Kossel, and I am using a RAMPS 1.4 board w/Arduino Mega 2560, and I am connecting it via USB. Any help would be great. Also, Ive set my printer shape to Rostock Printer (Circular print shape) and I can see a square shaped object on the virtual bed that is hollow on the top and bottom, which is far from the center of the circle. Is this normal? 

Thanks

Comments

  • Your object sounds wrong. Can you make a screenshot so I know what you mean.

    But that does not change z problem.
    1. test if you can send manually a
    G1 Z100 F6000
    and if that moves.
    2. If that works check in printer shape tab you set homing position to z max and printer height. Host will not move if you leave that area.
    3. Make sure to home first or depending on configs moves may be blocked from firmware side.
    4. Check endstops with M119 - should all be low for normal movement.

    Since homing works it must be some simple thing like not having a height and hence not being allowed to move or similar.
  • Sending the G-Code worked perfectly. And I don't understand #2. Do I set "Home Z:" to the height, in mm, from the bed to the end stops?  And when you say printer height, I assume you mean "Printable Height"?

    We originally had OctoPrint as our host, and it still works moving around (X-Y-Z)...So would that mean we can cross out firmware? 
  • Ok, first I see your square. That is a printer visualization demo. You can now add printer shapes as stl and you have enabled it in the printer shape tab at the bottom. Just disable checkbox.

    My guess is that you have set Home Z to 0 instead of printer height also in shape tab. You must there enter the geight returned by firmware when you have homed and send M114.
  • edited July 23
    Ah great that worked, thanks! Now, there's a situation I'm in if you don't mind. We just switched from using OctoPrint to Repetier, along with the Marlin firmware to Repetier firmware. We tried to set it up properly, but when we home it it gives me an error Error Hardware setup inconsistent. Delta connot home without max endstops, while hearing the printer's motors humming but not moving. 

    We used this https://www.repetier.com/firmware/v092/ for the firmware, and we ran M119 as what the instructions said to do to and it returned "endstops hit: x_min:L y_min:L z_min:L"
  • I've been having the same issue since updating. The old host used to have a "Home Z" MAX option, not just a set value. That way I could adjust the eeprom height and that would auto set to that when homed. Can that be added back in?
  • Yes we switched that since the old system does not work any more for all printers. My printer for example ends with z=10 after homing for safety reasons.
    Before it would read a coordinate output from firmware to set coordinates, which is why it worked despite wrong setting. Now this output is not reliable any more so we now ignore such outputs, so no we can not go back. Need to enter right value now.
Sign In or Register to comment.