How do I change the starting procedure

edited July 20 in Repetier-Host
If it helps I´m using a Wanhao i3.

My printer starts each printing by raising Z axel about 5-10mm, then waits for the temperatur to be reached and then starts to print. Why does it do that and how can I change it?

What I want is for it to go to and stay put in home position, heat up, and extrude some filament before starting printing. This way it gets more clean for my nozzle witch otherwise often gets some melted filament stuck on it.

I use the default starting Gcode and as far as I can tell there is no instructions to raise printer head?

; Default start code
G28 ; Home extruder
G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}



Comments

  • G1 Z15 F{Z_TRAVEL_SPEED}
    is the 15mm raise after homing.
    Some beds can melt if you have long contact with extruders, so heating at bottom height is bad for them. You would destroy the surface. If your bed can handle it, fine.
  • Ahh <span>:smiley:</span>
    Thank you, and I obviously need to check my eyes :)

    In my case I have an glass plate thats a little smaller than the bed so hotend is outside my surface.

    Have a great day!
Sign In or Register to comment.