g code for heat bed and fan not generated when using right extruder only

I am having to  manually control heat bed and fan when I use right extruder only. I have a Davinci 2.0.
#2 ext. is chosen and I have set the bed temp to 60 c, fan control to auto in the filament settings but Slic3r is not generating these when sliced. Please advise if I am missing something. Thanks in advance. 

Comments

  • Just tested with Slic3r 1.3.0 and it worked as expected. Maybe 1.2.9 which is bundled does behave different. Try the prusa engine slic3r which is also bundeled in 2.0.1.
  • Ok, Just tried it with the prusa version. Same behavior, not heat or fan generated. I also tried it with Cura and it worked. Not really familiar with Cura but will do some reading and testing. 
    I really appreciate your help.
    Thanks again for all of the hard work all of you are doing to make it easier for people like me.. ........  
  • In CuraEngine you can not use the second extruder only.

    Just see that forum software has reduced my answer to first section :-(

    Check slic3r_settings.ini in work directory - there it should write the values comma separated. For that reason it is important to not use a comma as decimal value like done in some countries. That might cause exactly your problem.
  • I see no comma used as a decimal value the slic3r_settings.ini.  Hopefully it will work in 1.3.0 when it comes out. 

    It's curious that Cura will generate the code for the right extruder only, but when the print starts it shuts off the extruder but goes through the motions of printing, although its off center. I know this is another topic and I will start a new post someday.
    Thank you again.


  • edited July 17
    Update,
    I created a filament setting called "no extrude", set the extruder temp to 0 and the bed settings to 65. I assigned it to the LEFT extruder and that worked for the the bed..... Still trying to figure out the fan. Will post back when I do
Sign In or Register to comment.