Home z-axis over bed instead of dump area Prusa

Is there a way to make the printer home Z at a particular position on the bed?

My homing order is set to XYZ.  It homes X and Y to the dump area and then tries to home Z.  There is physically no bed for the inductive sensor to read since the dump area is empty space.

Does it have anything to do with:
#define ZHOME_X_POS
#define ZHOME_Y_POS

Comments

  • use homing order 'Z up,x y preheat Z'

    then you can enter the x y location to home Z   'XY Homing pos. for Z'
  • edited July 12
    Thanks.  That works.  Is there a way to run G29 without "G29 leveling failed! ...".  It seems like I have to raise the z-axis 10mm before running G29 or else that message occurs.  Is there a setting or configuration to tell the z-axis to raise 10mm as part of the beginning of G29?

    18:01:56.508 : fatal:G29 leveling failed! Printer stopped and heaters disabled due to this error. Fix error and restart with M999.

  • Are you using G29 for bed levelling ?
    Repetier uses G32 for levelling  
  • edited July 13
    G32 does the same thing as G29 on my printer.  The z-min port is used by a micro-switch and the inductive sensor.  I
    think the problem is that a check is occurring to find if the height of the extruder is high enough.

    I thought this would solve it, but it didn't have an effect.
    #define Z_PROBE_START_SCRIPT "G0 Z10"
  • First you should use dev version for autoleveling as that has the most stable version. It will also give more information on fail. Typical reason for failure is 
    a) Start position does not allow activating z probe
    b) z probe triggered before going down.
    So make sure to go to a position where starting is possible. 
  • I would like G29 to move the z-probe to a safe position where z probe is not triggered.  For instance, G0 Z10.  Is there a way to set the start position automatically?
  • In dev version you can set 'allways raise Z 10' so when probing, Z will go up 10 then move to x y coords
  • Martin, what variable is that?
  • I think this does what you require

  • edited July 13
    G28 does work correctly with pre-raise.  After G28, I try to run G29.  G29 does not pre-raise like I want it to.  It moves horizontally to the bed and then has an error message.  I tried #define Z_PROBE_HEIGHT 10 and #define Z_PROBE_START_SCRIPT "G0 Z10".  The error message still occurs.

    13:01:00.604 : fatal:G29 leveling failed! Printer stopped and heaters disabled due to this error. Fix error and restart with M999.


  • Use G32 S2 for autoleveling. G29 just measures a average heigth from 3 points. For autoleveling use dev version whcih has the better implementation on this.
  • edited July 14
    G32 S2 has the same issue.  The bed leveling sensor starts at Z0 and moves horizontally to the bed.  The sensor triggers immediately and autolevel fails with an error.  Is there some way to make the sensor automatically move to Z10 before it runs the G32 S2 routine?
  • If you have z max homing it would bot so you need to move it to your desired probing height first. This is done since we can not know if you want it fast and thus start close or not. But it must not be triggered at start of course. 
  • I ended up using the (1)(2)(3)(4)(5) script buttons in Repetier Host for the two commands: G0 Z5; G32 S2
Sign In or Register to comment.