Unable to install RepetierHost 2.0+ on Linux

edited July 10 in Linux
Hi,

I have a fresh new install of Linux Mint 18.2 (it is based on Ubuntu).
I downloaded the latest 2.0.1 RepetierHost and extracted the files.
When trying to run "./configureFirst.sh", I'll get this error:

./configureFirst.sh 
System: x86_64
Using 64 bit CuraEngine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libmono-winforms2.0-cil is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  mono-reference-assemblies-2.0 mono-devel

E: Package 'libmono-winforms2.0-cil' has no installation candidate
Checking if you are in the dialout group.
1
User already in dialout group. Adding not required.
Compiling helper software to allow non ansi baud rates for some boards
depending on the used serial driver.
Configuration finished.
IMPORTANT: In addition to the bundled CuraEngine, the host also
supports Slic3r, Slic3r Prusa Edition and Skeinforge. These slicers are not bundled, so
need to install them according to their docs and then set the path
to them in Repetier-Host.
For Slic3r simply unpack the tar you get on http://slic3r.org in this directory.
For Slic3r Prusa Edition check https://github.com/prusa3d/Slic3r/releases
The host will then register and add it automatically on next restart.

IMPORTANT: You need a recent mono version since the host uses .NET 4.0
If you see the following error message, your mono is too old!
>>> System.Windows.Forms.SplitContainer doesn't implement interface System.ComponentModel.ISupportInitialize <<<
This folder now contains a repetier-RepetierHost.desktop file
Copy it to your desktop to get a launch icon there

I Google'd all over the Internet and tried to install the following packages:
I tried them from console with "apt-get install" and Synaptic Package Manager (it shouldn't be a difference though).
Neither option helped me. 

Any help would be really appreciated!

Comments

  • What is the error you get on startup if starting from console?
  • Repetier said:
    What is the error you get on startup if starting from console?
    I can't even execute ./configureFirst.sh, so how should I be able to start it from console?
  • You have successully installed it from from output. The problem is that linux changes so fast over time that depending on your distributaion and version some parts fail and others not. Try starting it amd then look further what might still be missing.
  • edited July 11
    [ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'RepetierHost.connector.SerialConnectionPanel:serviceRepetierServer' (2) due to: Could not load file or assembly 'System.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. assembly:System.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a type:<unknown type> member:<none>
      at RepetierHost.view.FormPrinterSettings.comboConnector_SelectedIndexChanged (System.Object sender, System.EventArgs e) [0x000a9] in <7f944aea11b94bbbb82caed051c2fe65>:0 
      at System.Windows.Forms.ComboBox.OnSelectedIndexChanged (System.EventArgs e) [0x00020] in <c86f0be4f9a847d3b8d63306221e6732>:0 
      at System.Windows.Forms.ComboBox.SetSelectedIndex (System.Int32 value, System.Boolean supressAutoScroll) [0x00093] in <c86f0be4f9a847d3b8d63306221e6732>:0 
      at System.Windows.Forms.ComboBox.set_SelectedIndex (System.Int32 value) [0x00000] in <c86f0be4f9a847d3b8d63306221e6732>:0 
      at RepetierHost.view.FormPrinterSettings.load (System.String printername) [0x000a9] in <7f944aea11b94bbbb82caed051c2fe65>:0 
      at RepetierHost.view.FormPrinterSettings.comboPrinter_SelectedIndexChanged (System.Object sender, System.EventArgs e) [0x00024] in <7f944aea11b94bbbb82caed051c2fe65>:0 
      at System.Windows.Forms.ComboBox.OnSelectedIndexChanged (System.EventArgs e) [0x00020] in <c86f0be4f9a847d3b8d63306221e6732>:0 
      at System.Windows.Forms.ComboBox.SetSelectedIndex (System.Int32 value, System.Boolean supressAutoScroll) [0x00093] in <c86f0be4f9a847d3b8d63306221e6732>:0 
      at System.Windows.Forms.ComboBox.set_SelectedIndex (System.Int32 value) [0x00000] in <c86f0be4f9a847d3b8d63306221e6732>:0 
      at System.Windows.Forms.ComboBox.set_Text (System.String value) [0x00068] in <c86f0be4f9a847d3b8d63306221e6732>:0 
      at RepetierHost.view.FormPrinterSettings.load (System.String printername) [0x00015] in <7f944aea11b94bbbb82caed051c2fe65>:0 
      at RepetierHost.view.FormPrinterSettings.LoadDefaultPrinter () [0x00057] in <7f944aea11b94bbbb82caed051c2fe65>:0 
      at RepetierHost.Main..ctor () [0x00412] in <7f944aea11b94bbbb82caed051c2fe65>:0 
      at (wrapper remoting-invoke-with-check) RepetierHost.Main:.ctor ()
      at RepetierHost.Program.Main (System.String[] args) [0x0000e] in <7f944aea11b94bbbb82caed051c2fe65>:0 

  • edited July 11
    That is fixed by: 
    sudo apt-get install libmono-system-serviceprocess4.0-cil

    Now RH starts up, looking for other errors.
Sign In or Register to comment.