Need help with RADDS on my Kossel XL Delta

edited July 9 in Questions & Answers
I created the firmware for the board on the site and uploaded it to the Due. When I try to move any of the axis all I hear are the motors turning. Could be the steps are off or other reasons. If you have a delta with raps 128 drivers could you link your config for a template?

(Update)

So X moves, but very slowly. When I home all/autohome, only x moves... 

Comments

  • Make sure you have seleted delta as printer type. Also after upload try
    M500
    M502
    top copy values from configuration.h to eeprom so these are used and not what you stored from previous uploads.

    If motors make a screaming sound they are loosing steps from being moved too fast. Might also that your substeps are not set correctly with jumpers.
  • I think I just need someone who has a delta config that works on their setup that I can get working on mine. 
  • All motors moving now. Though very slowly and lots of buzzing. Video here: 
  • 1. Home should start with up move, looks like they go down.
    2. Buzzing seems to be the problem. This happens e.g. when only one coil gets power or if the current is set too high on driver they also start singing. Too high stepper frequency is also a reason. Having bad contacts on all 3 motors is a bit unlikely except you needed to wire the cable yourself then you might have combined wrong cables the same way. But normally you get them with matching connectors.

    What steps per mm have you set in eeprom for which microstepping?
  • Repetier said:
    1. Home should start with up move, looks like they go down.
    2. Buzzing seems to be the problem. This happens e.g. when only one coil gets power or if the current is set too high on driver they also start singing. Too high stepper frequency is also a reason. Having bad contacts on all 3 motors is a bit unlikely except you needed to wire the cable yourself then you might have combined wrong cables the same way. But normally you get them with matching connectors.

    What steps per mm have you set in eeprom for which microstepping?
    That's an easy fix

    I'll check the driver's power

    80mm for all axis
  • 80 steps/mm is quite normal for deltas with 1/16 microstepping. What drivers are you using? Just saw you have a due and some stepper drivers like drv8825 need a longer high signal then due provides with no extra stepper high delay. Select expert mode in config tool to see these timings and set delay to 2 as a start point for testing. If it works go down to 1 if that works as any delay reduces max. frequency.
  • I'm using raps 128 set to 1/16 via dip switches. I'll try out the timings!
  • No luck...
  • raps128 do not need a delay. But they have the enable signal inverted which I guess you already did since they get turned on and move somehow. But what might be the case is that you are in 1/128 step mode so moves would be 8 times slower and shorter. See
    http://doku.radds.org/en/
    for description of jumper settings. And make sure current is set correctly. If enabled you should need a good force to move the glider. But also do not set too high as that gives jittering.
  • edited September 17
    I'm having the same slow movement problem as L0G4N using RADDS and due on a delta. It's not my microstepping, or my current. Homing is slow, XY motion is slow, Z motion is slow. I am using Ponterface to control the printer, and varying the speed setting is not making any difference. I am new to Repetier, not new to 3d printing.

    When I call M501, only 3 things show up from EEPROM:
    transformation matrix
    Select Extruder
    Flow Multiply

    There is no setting related to speed in EEPROM currently. Any solution to this? I looks to me like there are just no settings being written to EEPROM. I've tried uploading firmware using both EEPROM mode 1 and 2, no difference.
  • edited September 17
    Ok I figured it out. I downloaded Repetier Host and set the speeds in the EEPROM. Definitely confusing coming from Smoothieware, but I got it figured out now.
Sign In or Register to comment.