manual bedlevel

i know i can fit a probe and do it automatic

but since i have a dial gauge (messuhr) are there a way it can be done manual by visiting x,y cords and note the height?

my center height is 0mm and the 4 corner screws are also 0, but there is a slight bend in it so i thought doing it once manual was the most cost effective way

could be bump map be used or are there other ways it could be done?
«1

Comments

  • I have a similar question.
    How to enable manual calibration on four points? For manual adjustment with four screws?
  • hehe... i just turn the 4 screws so they are all the same height as center

    the trouble is that my bed is not complete flat so i can use the dial gauge and note down difference in grid style (my bed is a mk42 with 5*4 squares printed on the bed so it shuld not take long to note down X,Y and how much Z differs from 0
  • I would like that there was an item in the menu - Bed level. So that the printer moves through four points for calibration.
  • there is... kind of... disable steppers from the menu and moved the X and Y by hand and then adjust the screws
  • @boelle: You need to configure a z probe and enable distortion correction. This can be a fake just to get distortion map running. Just do not start any autolevel commands then. G33 L0 lists correction points and values. You can set all values manually as well using
    G33 X<pos> Y<pos> Z<correction>
    and then enable distortion correction.
  • thanks :-D

    time to work :-D
  • Q... i use https://www.repetier.com/firmware/v092/ to setup firmware

    at bottom of first page i set my probe to be able to reach the whole bed as i will not be using a probe anyway

    the Q is how to keep Z corrections during the whole print, do i just set DISTORTION_END_HEIGHT to 0 or do i set it to my max print height?

    since i use a mk42 bed i will have to figure a number that when divided with 250 or 210 returns a whole number

    could be nice if the grid could be a retangle instead of  sqaure... :-/
  • Please use dev version with G33, forgot to mention that 0.92 ha sit only working for deltas and not sure if you already can set it manually.

    DISTORTION_END_HEIGHT 0 means correct distortion until z=0 so makes no sense. If you need it just for good bonding use 1-2mm and set DISTORTION_START_DEGRADE to 0.5. If it is the x-axis that bends run full correction for full height.
  • nope its just the bed that is not flat... and you are right... 1-2mm makes more sense

    i figured the correction values by first zeroing the dial gauge in the center of the bed and then recorded the difference at each point in a grid style with 11 point on each axis

    look like this: https://docs.google.com/spreadsheets/d/15z7_7LNgL0F1sFTm9LYgB-lkbt0tR3B2PlJdKHjRR0E/edit?usp=sharing

    now i just have to enter the X and Y for each point so i can copy&paste to terminal
  • I always send G33 L0
    to get the list and copy the output. By design it has exactly the format to restore it, so you just copy your z values to coordinates and do the paste then.
  • So i have entered all the cord's and i can list them with G33 L0

    but even thou i lower the nozzle to 1mm and move the nozzle from repetier host it does not seem to do anything

    are there  other commmands i need to run to make it work? anything i can do to check i did not miss anything?
  • Since you can not run automatic measurement it does not get activated automatically, so you need

    - M323 S0/S1 enable disable distortion correction P0 = not permanent, P1 = permanent = default

    to enable it. Then go with z below the 100% correction level or you will not see the change depending on how you configure dit to reduce to 0% correction.

  • ahh, will try that tomorrow

    time to enjoy life outside the 3d world
  • worked, baby smooth 1st layer :-D
  • Q... i have made a clip on probe so that i can do automatic probing in 22*22 without spending days 

    will the distortion correction share the same data from eprom so that i can switch to distortion correction ?

    bed leveling is nice but there is not much need for it once i'm 1-2mm from the bed
  • btw sorry if my question is stupid... and my printer is not a delta
  • Not really sure what your questions is. Automatic distortion measuring with G33 will override your manual settings of course. If enabled it will always use the last stored correction.

    Autoleveling is independent, but once you change autolevel the distortion correction makes no sense. In fact normally you do autolevel and then distortion measurement. Then you can autolevel again if bed is not rotated so same bumps at same position and distortion stays correct. But if you did initially only distortion and then autolevel it will get wrong. Order matters here.
  • edited July 16
    My Q is if i can do an automatic disortion correction (using the probe) instead of automatic bed level

    bed level is a bit overkill once i get 2mm above the bed :-D
  • While you can the question is more if you should. If your be dis tilted 2mm you definitely should. If bed is more or less leveled and you just have bumps, then distortion only is a good solution to stop z moves on higher z levels.
  • i have just bumps.... that is why it does not make sense to have the z motors working above 1-2 mm up from the bed
  • but of course its nice to have both functions working :-D

    so i guess that i have to disable (FEATURE_AUTOLEVEL)

    and enable (DISTORTION_CORRECTION) + (DISTORTION_PERMANENT)

    DISTORTION_START_DEGRADE is set to 0.1
    DISTORTION_END_HEIGH is set to 2

    in that way the correction is slowly turned off over 20 layers

    only thing i need to change are the DISTORTION_XMIN, DISTORTION_YMIN, DISTORTION_XMAX and DISTORTION_YMAX, but i guess i can take them from the autolevel setup
  • my config after the changes: https://pastebin.com/paKGUqy2

    does it look ok or is there something wrong?
  • Not sure if FEATURE_AUTOLEVEL should be disabled, might be needed to compile distortion, but no need to enable it.
    Looks at configs are useless - I can not say if a config is good or not by looking to it. It just needs to be tested to tell that.
  • it worked fine... it just takes a lot of time if going for 22 points on each axis.. nice it only have to be done one time

    i must have made a mistake because it seems i can never get the perfect first height

    my machine is set to home to max... so i home and ask it to go to Z1

    i then lower z by 0.1mm and i end up with touching the bed at 0.7

    i then lower my Z max height in eeprom ..... home Z and try again... i'm still 0.7mm up when i touch the bed

    are there a command i can do to get the correct Z height without probing the bed again?

    i mean once i know i have my nozzle just perfect could the machine figure out the Z height?

    G33 S2?
  • Quote:

    my machine is set to home to max... so i home and ask it to go to Z1

    i then lower z by 0.1mm and i end up with touching the bed at 0.7

    i then lower my Z max height in eeprom ..... home Z and try again... i'm still 0.7mm up when i touch the bed



    seems you mixed directions:

    if you are touching bed at 0.7  you have to Raise Zmax by 0.7




  • Machine height is measued by G32 S2 as well and depends on z probe height you also use for G33. Dev version has a menu entry to measure it with a block of known height.

    Reducing z length should reduce the point where z = 0 is. All you would need is rehome. Depending on configuration you might even have the set z=0 menu entry which would also do that. But that does not appear on all configurations. If it doe snot change check if it was copied to eeprom.
  • "if you are touching bed at 0.7  you have to Raise Zmax by 0.7"

    if i raise z max length it will be able to travel 0.7 more and it would now touch the bed at 1.4mm since it now thinks i can travel 0.7mm lower than before

    so no i dont think i got it wrong... mendel90's standard config has always been that it goes up when it homes. when it hits the zmax endstop it knows how far down the bed is.

    Will G32 S2 require the probe? i wanted to avoid having to mount it again, its a clip on probe that i only connect when i do the probing.

    i get my perfect Z=0 by manual lowering the nozzle and then i send gcode to make it extrude a long thin line... i examine the line and then i either lower or raise Z to get the perfect shape on the extruded filament..

    i then know i have the right height...
  • G32 S2 does not work

    17:44:39.549: Unknown command:N23999 G32 S2
  • well found one small mistake...

    my probe triggers at 6,23 and release at 6,94

    but in firmware its set to 13,353

    will correct this and run a new G33... or was the G32 S2 meant to be G33 S2 ?
  • https://www.repetier.com/documentation/repetier-firmware/z-probing/

    last 2 lines at the end of the page says that if i do have a max z endstop it will meassure the height... 

    for me that includes it will home to up the the max endstop after it has done probing

    it have just tested it with 4 probes on X and Y to make it fast, but it does not home to Z max endstop after the last probe
Sign In or Register to comment.