DaVinci 1.0a motors not moving

Hey everyone, so after some tinkering I finally got my bed and extruder to heat without failing. 
Now I'm at another issue, the motors aren't moving. 
I can't move them through the software or the on-machine buttons. Also I'm not sure how to home once I've gotten the motors to move. I've pasted the log below 
Any suggestions are greatly appreciated. I can't wait to get this thing going!

Thanks
Eric


This begins right about the time I slice the object, it seems to think it's printing but the machine does nothing. 
I am able to heat/cool the extruder and bed through the software
------------------------------------------------------------------------------------------------------------
09:36:32.333 : Exception has been thrown by the target of an invocation.
09:36:33.905 : Plugin SlicerSlic3r.SlicerSlic3r:An item with the same key has already been added.
09:36:33.957 : Plugin SlicerSlic3rPE.SlicerSlic3rPE:Could not load type 'RepetierHostExtender.geom.IModelMetadata' from assembly 'RepetierHostExtender, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
09:36:34.254 : OpenGL version:4.0.0 - Build 10.18.10.4276
09:36:34.254 : OpenGL extensions:GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_ARB_map_buffer_alignment GL_ARB_conservative_depth GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_SUN_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_ARB_texture_swizzle GL_EXT_texture_swizzle GL_ARB_texture_gather GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_ARB_transform_feedback2 GL_ARB_draw_indirect GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_ARB_framebuffer_no_attachments GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_ARB_texture_buffer_range GL_EXT_texture_buffer GL_EXT_texture_snorm GL_ARB_blend_func_extended GL_INTEL_performance_queries GL_INTEL_performance_query GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_geometry_shader4 GL_EXT_geometry_shader4 GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_base_instance GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_texture_multisample GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_ARB_tessellation_shader GL_ARB_vertex_array_object GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_texture_cube_map_array GL_EXT_gpu_shader4 GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_shader_subroutine GL_ARB_transform_feedback3 GL_ARB_get_program_binary GL_ARB_separate_shader_objects GL_ARB_shader_precision GL_ARB_vertex_attrib_64bit GL_ARB_viewport_array GL_ARB_transform_feedback_instanced GL_ARB_compressed_texture_pixel_storage GL_ARB_shader_atomic_counters GL_ARB_shading_language_packing GL_ARB_shading_language_420pack GL_ARB_texture_storage GL_EXT_texture_storage GL_ARB_vertex_attrib_binding GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_texture_storage_multisample GL_ARB_buffer_storage GL_ARB_debug_output GL_KHR_debug GL_ARB_arrays_of_arrays GL_INTEL_map_texture GL_ARB_texture_compression_bptc GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_robustness GL_EXT_texture_sRGB_decode GL_KHR_blend_equation_advanced GL_EXT_shader_integer_mix GL_ARB_stencil_texturing 
09:36:34.255 : OpenGL renderer:Intel(R) HD Graphics 2500
09:36:34.255 : Using fast VBOs for rendering is possible
09:36:37.551 : The port 'COM3' does not exist.
09:36:50.633 : The parameter is incorrect.

09:37:01.381 : The parameter is incorrect.

09:37:20.717 : The parameter is incorrect.

09:38:34.956 : The parameter is incorrect.

09:39:21.880 : Starting object analyser ...
09:39:22.503 : Object is manifold.
09:39:22.512 : Analysing finished.
09:39:26.996 : CuraEngine command:C:\Program Files\Repetier-Host\plugins\CuraEngine\CuraEngine.exe -p -v -c "C:\Users\User\AppData\Local\RepetierHost\cura.ini" -s posx=0 -s posy=0 -o "C:\Users\User\AppData\Local\RepetierHost\composition.gcode" "C:\Users\User\AppData\Local\RepetierHost\composition0.stl"
09:39:27.412 : <CuraEngine> Cura_SteamEngine version 14.12
09:39:27.412 : <CuraEngine> Copyright (C) 2014 David Braam
09:39:27.412 : <CuraEngine> This program is free software: you can redistribute it and/or modify
09:39:27.412 : <CuraEngine> it under the terms of the GNU Affero General Public License as published by
09:39:27.412 : <CuraEngine> the Free Software Foundation, either version 3 of the License, or
09:39:27.412 : <CuraEngine> (at your option) any later version.
09:39:27.412 : <CuraEngine> This program is distributed in the hope that it will be useful,
09:39:27.412 : <CuraEngine> but WITHOUT ANY WARRANTY; without even the implied warranty of
09:39:27.412 : <CuraEngine> MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
09:39:27.412 : <CuraEngine> GNU Affero General Public License for more details.
09:39:27.412 : <CuraEngine> You should have received a copy of the GNU Affero General Public License
09:39:27.412 : <CuraEngine> along with this program.  If not, see <http://www.gnu.org/licenses/>.
09:39:27.412 : <CuraEngine> Default config 'default.cfg' not used
09:39:27.412 : <CuraEngine> Loading C:\Users\User\AppData\Local\RepetierHost\composition0.stl from disk...
09:39:27.459 : <CuraEngine> Loaded from disk in 0.047s
09:39:27.459 : <CuraEngine> Analyzing and optimizing model...
09:39:27.627 : <CuraEngine>   Face counts: 148524 -> 148228 99.8%
09:39:27.627 : <CuraEngine>   Vertex counts: 445572 -> 74074 16.6%
09:39:27.627 : <CuraEngine>   Size: 188.047000 188.047000 22.611000
09:39:27.627 : <CuraEngine>   vMin: 5.976000 5.976000 0.000000
09:39:27.627 : <CuraEngine>   vMax: 194.023000 194.023000 22.611000
09:39:27.629 : <CuraEngine>   vMin: 5.976000 5.976000 0.000000
09:39:27.631 : <CuraEngine>   vMax: 194.023000 194.023000 22.611000
09:39:27.632 : <CuraEngine>   Matrix: 1.000000 0.000000 0.000000
09:39:27.632 : <CuraEngine>   Matrix: 0.000000 1.000000 0.000000
09:39:27.632 : <CuraEngine>   Matrix: 0.000000 0.000000 1.000000
09:39:27.632 : <CuraEngine> Optimize model 0.171s 
09:39:27.632 : <CuraEngine> Slicing model...
09:39:27.632 : <CuraEngine> Layer count: 113
09:39:28.129 : <CuraEngine> Sliced model in 0.500s
09:39:28.129 : <CuraEngine> Generating support map...
09:39:28.133 : <CuraEngine> Generating layer parts...
09:39:28.316 : <CuraEngine> Generated layer parts in 0.187s
09:39:29.339 : <CuraEngine> Generated inset in 1.014s
09:39:33.268 : <CuraEngine> Generated up/down skin in 3.931s
09:39:40.110 : <CuraEngine> Wrote layers in  6.85s.
09:39:40.185 : <CuraEngine> Wrote  12.7 MB.
09:39:40.187 : <CuraEngine> Total time elapsed 12.78s.
09:39:40.195 : <CuraEngine> Print time: 11649
09:39:40.196 : <CuraEngine> Filament: 11291
09:39:40.196 : <CuraEngine> Filament2: 0
09:40:42.731 : FIRMWARE_NAME:Repetier_0.92 FIRMWARE_URL:https://github.com/luc-github/Repetier-Firmware PROTOCOL_VERSION:1.0 MACHINE_TYPE:DaVinci EXTRUDER_COUNT:1 REPETIER_PROTOCOL:2
09:40:42.731 : Printed filament:0.00m Printing time:0 days 0 hours 0 min
09:40:42.744 : Error:M114
09:40:42.744 : X:NAN Y:NAN Z:NAN E:NAN
09:40:42.745 : Begin file list
09:40:42.794 : ad_check_0002 1400
09:40:42.794 : Machine_Life.dat 16
09:40:42.794 : SAMPLE01.gcode 2674343
09:40:42.796 : SAMPLE02.gcode 426855
09:40:42.799 : SAMPLE03.gcode 3829421
09:40:42.852 : last_temperature.txt 2
09:40:42.855 : offline_print.gcode 744544
09:40:42.857 : eeprom.bin 4096
09:40:42.860 : cached.g 19
09:40:42.861 : ad_check_0001 2400
09:40:42.867 : End file list
09:40:59.741 : X:0.00 Y:0.00 Z:0.000 E:NAN
09:40:59.769 : Unknown command:N23 M107
09:40:59.802 : Printing layer 1 of 113
09:41:36.889 : Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
09:41:37.520 : Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
09:41:38.687 : Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
09:42:05.052 : Unknown command:N30 M107
09:42:14.209 : Printing layer 2 of 113
09:42:14.214 : Unknown command:N6108 M106  S63
09:42:22.690 : Printing layer 3 of 113
09:42:22.696 : Unknown command:N11597 M106  S127
09:42:32.777 : Printing layer 4 of 113
09:42:41.114 : Printing layer 5 of 113
09:42:48.651 : Printing layer 6 of 113
09:42:56.126 : Printing layer 7 of 113
09:43:03.928 : Printing layer 8 of 113
09:43:11.496 : Printing layer 9 of 113
09:43:11.608 : Error:expected line 43697 got 43698
09:43:11.610 : Resend:43697
09:43:19.135 : Printing layer 10 of 113
09:43:26.641 : Printing layer 11 of 113
09:43:27.238 : Error:UI_ACTION_ZPOSITION
09:43:27.240 : X:NAN Y:NAN Z:NAN E:NAN
09:43:34.157 : Printing layer 12 of 113
09:43:35.050 : Error:UI_ACTION_ZPOSITION
09:43:35.052 : X:NAN Y:NAN Z:NAN E:NAN
09:43:41.505 : Printing layer 13 of 113
09:43:43.516 : X:1.00 Y:0.00 Z:0.000 E:NAN
09:43:43.516 : X:1.00 Y:0.00 Z:0.000 E:NAN
09:43:44.145 : X:1.00 Y:0.00 Z:0.000 E:NAN
09:43:44.148 : X:1.00 Y:0.00 Z:0.000 E:NAN
09:43:45.121 : X:1.00 Y:0.00 Z:0.000 E:NAN
09:43:45.125 : X:1.00 Y:0.00 Z:0.000 E:NAN
09:43:46.004 : X:1.00 Y:33.00 Z:0.000 E:NAN
09:43:46.008 : X:1.00 Y:33.00 Z:0.000 E:NAN
09:43:48.776 : Printing layer 14 of 113
09:43:55.398 : Printing layer 15 of 113
09:44:02.780 : Printing layer 16 of 113
09:44:10.283 : Printing layer 17 of 113
10:08:42.115 : X:1.00 Y:0.00 Z:0.000 E:NAN

Comments

  • 09:40:42.744 : Error:M114
    09:40:42.744 : X:NAN Y:NAN Z:NAN E:NAN

    you should check your eeprom. I guess it contains some invalid numbers causing NaN which prevents movements.
  • Repetier said:
    09:40:42.744 : Error:M114
    09:40:42.744 : X:NAN Y:NAN Z:NAN E:NAN

    you should check your eeprom. I guess it contains some invalid numbers causing NaN which prevents movements.
    Thanks,
    Can you walk me through how to check that?
  • Just check for nan and 0 where a value is needed.
    You can also overwrite with configuration settings
    M501
    M500

    Which should also fix that. This happens if you change to add new functions after first upload, then new functions are not initialized since they did not exist before.
  • i think you mean

    M502
    M500
  • Thanks for the info but I'm very new to 3d printing and arduino as a whole. 
    What i have so far are two configurations that i've loaded to the machine that will work some of the functions. The first is the config files that I downloaded from here: https://www.thingiverse.com/thing:1648104 That one will heat the extruder and bed and Repetier Host connects to the machine but won't move the motors. This is the firmware I have installed right now and was in use when I copied the errors
    The other is the is linked below which won't move the motors or heat the extruder. When I checked the extruder leads there was no power
    https://github.com/luc-github/Repetier-Firmware-0.92 I did make sure to set the model in the configuration.h file

    I hate to ask for detailed instructions but this is the first time I have opened a programming console since VB in college probably 13 or so years ago.  :-)
    Where can I check for  nan and 0? are those in the repetier.ino file? I'm not aware of any way to open/edit the .bin file
  • Alright, I did some more tinkering. 
    With the firmware from Luc, the left pin for the extruder reads 12.18v if I hold my multimeter to a ground on the board or chasis, testing with COM on the right pin, it reads 0V
    I tried grounding the wire from the left pin with Luc's firmware installed, the extruder heated but continued heating until it got to 255 degrees, then I shut the machine down.

    With the Thingiverse firmware I get between 12.03v and 12.18V (corresponds with heating and cooling to maintain the temp) with the + lead on the left pin and COM lead on the right, temp ranged 205 to 215
    Extruder temp was set in the software to 210 for both tests
    So, I'm going to assume there is something wrong about the pin settings in Luc's arduino file from Github?
    I'd like to get that working then tackle the movement since I can edit the arduino files from Luc and not the thingiverse .bin file
    This is a 1.0A version of the printer, if that helps. I've attached a photo of the board
    I have also been poking around at the arduino configuration files and am confident that I can modify what needs to be, I'm just not sure what those settings are going to be. 
    Is there a way to determine what pins numbers are on the board?
  • I found the EEPROM settings in Repetier Host, several of the settings have 0s in the field. I'm not in front of that computer right now but I do remember that almost if not all the settings dealing with x-y-z movement were 0

    What is a good starting point for adjusting those settings?

  • Accelerations 1000 except z there 50. Steps per mm what is required, max speeds 200 and Z needs testing 5 normally always goes and depending on printer up to 40 and more.

    Accelerations can normally be increased but makes printer jerky. jerk 20, z jerk 0.3
  • Hi again, 
    I was able to get the motors spinning and the printer printing again. 
    Thanks for all your help. 

    Eric
Sign In or Register to comment.