How-to activate/configure auto bed leveling with z-probe properly?

Today I wanted to switch back to latest dev version of repetier, coming from marlin, but doesn't like it as much as repetier.

Sadly I can't find the proper way to configure auto bed leveling properly! The configure I had half a year ago doesnt work anymore with the latest dev version.

This is my configuration at the moment:

Comments

  • edited May 5
    Most of it looks good.

    What type of probe are you using ?
    If you are using the probe as the Z min endstop, you need to enable Z min endstop (under mechanics) in the config tool.
    Or you could use a mechanical Z max endstop.


    ps. dont forget, bed levelling on repetier is done with G32  not G29 :)
  • Hey MartinH,
    thanks for your reply.

    I know also set the probe as z min endstop. But I get the same error as before:
    READ: Error:Activating z-probe would lead to forbidden xy position: 5.000000, -85.00
    READ: RequestStop:
    SENT: M105
    READ: fatal:Could not activate z-probe offset due to coordinate constraints - result is inaccurate! Printer stopped and heaters disabled due to this error. Fix error and restart with M999.

    I don't know why is is saying the forbidden position thing. The measure runs normally after that error, but cant work with the printer because of that error.
  • Your z-probe has a offset. To measure it gets activated and if that means move extruder left and you are at x=0 this is not possible-> illegal position.
    Use homing sequence with preheat as these allow to set a probing position as well that would allow activating z probe.
  • edited May 6
    Ok, so just to get that clear.
    I set homing_order to x y preheat then z. Also probe as z-min endstop.

    Proper way then to get started:
    G28 X0 Y0
    Preheat extruder/bed
    G32

    Correct?
    Should the probe also just work that way as endstop? Without leveling? Because this is not working at the moment, it first approaches the bed, goes a little bit up and then crashes into bed.

    Edit:
    Just to be clear, I got an offset of 9cm between extruder and probe in y-axis (I know this is much, but I just need to get it printing again, so I can print parts for the ir probe to get it near the extruder).
    I'm homing first x and y, and when extruder is at x0 and y0 i start probing.
  • I allways start with G28   home X Y and Z.  followed by G32 S2 (only need do G32 once as results are stored in eeprom)

    make sure you have set the Z homeing X Y coords in end stop section of config tool

    image
  • I got in somehow working, but not as it should be I think. At the moment I just can get in running, when doing a G28 X0 Y0, and a G32 after that.

    As soon as I wanna home z axis, i'm getting the illegal position error. My homing order is configured as in the screenshot, I just have the pre raise z only when z-min is active. And z-min as switch on gnd, normally open.
  • G32 is autoleveling not homing. For homing you should just send
    G28

    and it should home including z with your z probe. The settings above are for homing not G32. Start G32 at X100 Y100 and it should also succeed.
  • I know that G32 is just for auto leveling. And this works, when the extruder is at x0 and y0. But when I send a G28 or just G28 Z0 I'm getting the illegal position error.
  • Did you set the ' X Y homing pos for Z'

  • I think G32 goes first to P1 and then activates probe so it does not activate at 0,0.
  • edited May 21
    So, I now switched to ir probe. With less distance to hotend. This is my current configuration: https://pastebin.com/ZdLCn7Zq I dont have the illegal position error anymore, but I also changed somethings in the config. Problem now is, that 8 of 10 times the hotend crashes into bed when using G28 command. 
  • Does it trigger also below trigger height? If not starting with low z will not see signal and crash into bed. Then you can set to go up before homing so you are sure it passes trigger height.
  • edited May 23
    What exactly do you mean below trigger height? With a G32 the probe is measuring without crashing into bed.

    I configured z should always go up 20mm before homing.

  • And for G28 you have set z min endstop = z probe endstop I assume. With 20mm going up before it should always succeed if there is no special treatment required for probe. Only make sure you have homing order with XY before Z.
  • I did all this but didnt change a thing.

    But yesterday I loaded the latest dev version and the problem is gone. Don't know if you changed something. But I can't get a proper height when using a normal G28. Only way its working properly is G28 X0 Y0 and G32.

    I even tried G33 and had kind of success but something must be wrong with my bed, because I can't get a good first layer. With small objects that isn't such a problem, but bigger things just dont work. On one side the nozzle is to close too bed and on the other its to far away. With just doing a G32. When doing a G33 it was a litte bit better. But I cant do a G32 together with G33. When I do a G32 before a G33, I'm getting illegal position error with G33.

    If I just do a fresh start without a G32 and just doing G33 its working. The also which is kind of weird, is that the G33 is starting in the top left corner of my bed, and a G32 is starting in the bottom left corner. Is that behaviour normal?
  • G32 and G33 are independent and have own areas which can differ and ordering can be different, that is normal.
    Run G1 X100 Y100 and start G33 after G32. That should allow activating z probe.

    Make sure bed coating is 0. This is added to G28 in comparison to G32 so might be the reason.
  • The G1 X100 Y100 did the trick!
    Thank you very much. Will now test everything.
Sign In or Register to comment.