WIFI connection lost (RASPI)

I do have the 2.5amp power supply for the raspberry pi. I used the image provided on the website for it. It setups and prints fine. But it seems it loses connection frequently. When I do restart it, i have to type the router password back in which is a pain. I want this thing to not lose connection as I am remote most of the time.

Comments

  • When you are connected login via ssh

    cd /usr/local/Repetier-Setup/bin
    sudo mv manageWifiAccess manageWifiAccess_off
    sudo service RepetierServer restart

    This disables the wifi managent from server side. Since you do this while connected NetworkManager will always reconnect on it's own if possible. This will be the next solution with new release. If you still get disconnections after this it is from bad connectivity of wifi and nothing we can improve. But it shoudl always reconnect as soon as possible on it's own.
  • Ok I set it up and going to try it. My raspi is no further than 4 ft away from my wifi which is the newest kind of router.
  • I'm quite confident it improves. I'm working on new wifi handling and found out that NetworkManager does a bit more then expected so it really reconnects on it's own.

    On the other side for 4ft I would use a ethernet cable just because it is faster and even more reliable.
  • Seems like it worked. By the way, I found that your front end runs off angularJS. I was able to manipulate the code to provide all features of paid. But I did buy the license just to support the software since it beats the PI. Figured I'd give you a heads up, maybe obscure the code.
  • Design was so you can add features with modules if needed, so obscuring is maybe not best solution.

    While you can hack some pro features in frontend the backend also does some stuff only when license is installed. But in the end we hope there are enough sincer users that support further development with buying a license.
  • Repetier said:
    I'm quite confident it improves. I'm working on new wifi handling and found out that NetworkManager does a bit more then expected so it really reconnects on it's own.

    On the other side for 4ft I would use a ethernet cable just because it is faster and even more reliable.
    I have the same problem with Pi3 and i make lots of machines with this so when will your image be updated?
  • We are working on it and hope in may.
  • Hello members
    I made a mistake,
    I disagreed the WLAN access this command "sudo mv manageWifiAccess manageWifiAccess_off"
    There is a way to enable ??

    many thanks
  • I have had 2 faulty Pi3's now both with wifi hardware problems that could not connect at all.
  • @maralb you need to rename it back. IF you have a display connect keyboard ant alt+2 I think to get a login text window. Otherwise connect to ethernet so you can login again.

    @3DBRINK we are overhauling the wifi management making it more versatile and less invasive in case of short disconnections. Only when 2 minutes no connection can be established we will switch to access point.
  • thanks Roland
    I installed a new image
    Formatted everything
    sorry
Sign In or Register to comment.