Killing my head with Wifi on Raspberry !

Hi

I installed the Raspberry image you list on website on a Raspberry 3. First time I started it, I made configuration of server including connect it at my Wifi through the Web Interface.
I made also the modification listed in FAQ to prevent deletion of Wifi configuration if it looses Wifi or restart while Wifi is off.
My only problem is that now it always start in AP mode. If I select my Wifi in web interface it doesn't ask for password ! I loose network connection during 30s and then it goes back in AP mode.
Can I fill all Wifi details in the server.conf file in the Raspberry ? and if so how to tell him to consider these settings to access an AP and not be an AP ?

Thanks,

Vincèn

Comments

  • Posts: 0
    You can simply rename the wifi manager script so server does not try to manage your connections. Then it will never go into AP mode and keep the settings you had when renaming the file (so do so when wifi is connected).

    Next release will get some changes in wifi handling e.g. a file containing connection data to be used. 30s is also update frequency of servers wifi data so it could be it never connected if it is only 30s.

    Have you checked how good the signal is?
    /usr/local/Repetier-Setup/bin/wlanscanner

    shows you signal strength.
  • Posts: 10
    Thanks for the explanation so I better understand the problem but it still doesn't resolve my issue that it doesn't connect anymore at my AP now :( Isn't it possible to code AP/pass/crypt in a file so he can use it at startup ?

    I get very strong signal (short distance and line of sight in fact, I use WIfi only because it's impossible to pass a cable unless short distance !)
  • Posts: 0
    Currently the image does not support this. We want this in next release - a simple textfile readable from any os where you can set your connection data. 

    If you use the standard image and install server there, you would use wpa_supplicant to store your single password. But this system does not allow AP which is why we are using networkmanager, and since we wanted to make it easy also a gui for setting it. But is seems to be not that easy to get it do what is expected on all systems. So now we scan wifi list and if your is not listed disconnect and switch to AP. Problem is as you might know that sometimes not all stations are listed so that might be the reason. So an other improvement is only to switch to AP if wifi is not connected regardless of seeing not the ssid. But that will be on next image.
  • Posts: 10
    Repetier said:
    If you use the standard image and install server there, you would use wpa_supplicant to store your single password. But this system does not allow AP which is why we are using networkmanager, and since we wanted to make it easy also a gui for setting it. But is seems to be not that easy to get it do what is expected on all systems. So now we scan wifi list and if your is not listed disconnect and switch to AP. Problem is as you might know that sometimes not all stations are listed so that might be the reason. So an other improvement is only to switch to AP if wifi is not connected regardless of seeing not the ssid. But that will be on next image.
    Unhappy my AP appears always in GUI but now when I click on it, it switches few seconds to connect at my AP and then come back in AP mode :( It doesn't even ask for my Wifi password :( I guess I have no other solutions than to crash everything and reinstall my Pi no ?

    For the next version nothing testable yet ?? Would be happy to test and give feedback and help also for translations in french (missing ones and some are wrong !!)
  • Posts: 0
    With ethernet you can always get access. I know to far away but a pi is small and can be moved for installation.

    If you had deleted the delete password as described in image faq it should not ask for password anyway.
  • Posts: 10
    Repetier said:
    With ethernet you can always get access. I know to far away but a pi is small and can be moved for installation.

    If you had deleted the delete password as described in image faq it should not ask for password anyway.
    Oki so waiting for next update of Server with Wifi more efficient, I pulled a cable, plugged it on Pi, rebooted it and now both Wifi and LAN are working :D
Sign In or Register to comment.