Autolevel on Delta leads to printing above bed

edited March 29 in Repetier-Firmware
I have a home built delta printer which I'm trying to get working with Repetier firmware.
I'm trying to get autoleveling to work with a Z probe actuated microswitch.
Everything seems to be working correctly running G32 S2 command, except that after calibration, the printer will try to print the first layer about 1mm above the bed.
I thought it was a matter of the Z Probe offset, but before starting the print, if I move the hot end to Z0 it will descend down and touch the bed.
The problem is only apparent when I start a print.

Any ideas as to what settings I should be looking at?

Thanks.
BTW, I'm running a RAMPS 1.4 board.

Comments

  • Posts: 0
    Printer height is computed wrong (1mm to small here). This can be influenced by z probe height changing it by +1mm and rerun G32 S2. Then homing should go 1mm deeper.
  • Posts: 2
    Thanks for the response.  

    Not sure what has changed, but when I went through the process of recalculating the Z probe height offset and re-entered it in, for some reason things have started working correctly.  Note that the offset I put in is essentially identical to the original setting.
    (3.84mm vs 3.82mm originally).
    Am I correct in thinking that G32 S2 command will automatically save the measured parameters to firmware?
    The previous behaviour was almost as if the auto bed level parameters were lost after re-homing at the start of a print.

    Thanks in any case.  This is my first printer with Repetier firmware (other printers have either Marlin or Reprap Firmware) and so far the performance on a Delta is definitely a step up on Marlin/RAMPS.
Sign In or Register to comment.