XYZ max and min travel

I have three problems first is I need to know is there a way two have XY and Z axis set themselves to 0 after homing? My 2nd problem is when I turn on machine and host, it is at zero, I put in a G00 Z300 and the bed only moved about 1.5in and stops, yet in the host aitnd controller it reads Z is at 300. Is there anyway to allow printer full movement in the XY & Z axes until they hit an endstop which I have six of?(I have XY and z end stops settings in firmware all set to true I have minimum and maximum distance for all three set to way above and below what they should be)Also when XY or Z does hit an end stop is there any way to disable the host controller to also stop moving or counting up and or down? Thank you

Comments

  • Homing = G28 homes to min or max depending on configuration and sets coordinates correctly. Only after that you should start moving around.

    You need configure firmware correctly especially steps per mm. If you move z300 and it does not move 300mm and does not hit endstop it is likely your steps per mm are not high enough. Or endstop was triggered by crosstalk.

    Host will prevent moves outside allowed area after homing if you set up the right dimensions in host. These should be slightly smaller then required to reach opposite endstop, which should never happen. They are for safety and not for being hit during operation except homing.
Sign In or Register to comment.