Z-axis stepping issues

Q3 ThreeUp V3 printer. Arduino 2560 and Ramps 1.4.

X and Y axis move correctly under manual control and print correctly and to scale.  The Z axis has 2 NEMA 17 stepper motors and twin screws.  When I manually press the Z-Axis 0.01 button the Z-axis moves on average 0.1 mm.  When I press the Z-Axis 0.1 button the Z-axis moves on average 1.1mm.  If I press the Z-Axis 1.0 button the z-axis moves momentarily and then stops and the motors make a whining sound.

The stock configuration is:

#define DEFAULT_AXIS_STEPS_PER_UNIT   {88.88888888889,88.88888888889,1511.811023622047,88.57326053533955}
#define DEFAULT_MAX_FEEDRATE          {500, 500, 5, 45}
#define DEFAULT_MAX_ACCELERATION      {5000,5000,100,10000}

#define DEFAULT_ACCELERATION          5000 
#define DEFAULT_RETRACT_ACCELERATION  5000 

I have played around with these numbers and have had no luck to get the Z-axis to move to scale:

11:27:52.344 : echo:  M92 X88.89 Y88.89 Z1511.81 E88.57
11:27:52.345 : echo:Maximum feedrates (mm/s):
11:27:52.347 : echo:  M203 X500.00 Y500.00 Z2.00 E45.00
11:27:52.348 : echo:Maximum Acceleration (mm/s2):
11:27:52.351 : echo:  M201 X5000 Y5000 Z6 E10000
11:27:52.354 : echo:Accelerations: P=printing, R=retract and T=travel
11:27:52.355 : echo:  M204 P5000.00 R5000.00 T5000.00
11:27:52.363 : echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
11:27:52.366 : echo:  M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00

Comments

  • Firmware is just configured wrong. Correct z steps per mm and it should be ok.
  • I have modified the z steps from 1151.81 to 50% at 573.18 and it did nothing.  When I double the z up to 2560 the stepper motors whine and don't move at all.
  • Also, when I print a 20mm calibration cube, it prints perfectly in X and Y but is 40mm in Z.
  • check your jumpers under the Z driver?
  • edited March 12
    As roko said , allso
    What type of Z screws are fitted, ie  5mm thread rod or 8mm or 4 start lead screw ?

  • Roko said:
    check your jumpers under the Z driver?
    This helped tremendously.  The original kit did not have jumpers under the z-stepper.  I added 3 jumpers for MS1, MS2 and MS3 and the print quality went way up.  The 20mm cube went from 40mm in the z-axis to 15mm.  I pulled the MS3 jumper to reduce to 1/8 microstepping to see if that would get the z to 20mm but it went over 20mm.  So I will keep all three jumpers but I am not sure how to get the cube back to 20mm.  Maybe layer height?
  • MartinH said:
    As roko said , allso
    What type of Z screws are fitted, ie  5mm thread rod or 8mm or 4 start lead screw ?

    Well, I cannot tell.  The kit decided to leave out that important information.  Outside measures 10mm, inside threads is 8mm and there are 13 threads per inch (well more or less).
  • Fixing z steps per m is the only way to fix the last difference. Can not say how to do this correctly with marlin. Normally i would just change it in config and reupload. If they do not use it from eeprom it should suffice.
  • edited March 12
    From what I recall, using Rep-Host  with Marlin, under config - firmware you can change steps/mm and save to EEPROM. The screen is a little different. I would also change the configuration file to the new steps so if you reload firmware you won't have that problem again..
  • edited March 12
    From looking at the kit details  i would say you definitly have 4 start lead screws on the Z axis, so you will
    most likely need 400 steps/mm with a max feedrate of about 30. You should be able to edit these in the eeprom
    via rep host.

    Allso, leave the 3 jumpers installed for 1/16 microstepping
  • from your description it´s a TR 10x2 thread  and it will need 1600 steps /mm  at 1/16 microstepping with a 200 steps/rev motor

  • Repetier said:
    Fixing z steps per m is the only way to fix the last difference. Can not say how to do this correctly with marlin. Normally i would just change it in config and reupload. If they do not use it from eeprom it should suffice.
    Thanks, that worked good.  I determined the % out the 20mm cube was in the Z axis and applied that to Z steps and it came out almost perfect.  All of this was done through RH.  For anyone else with this problem:  go to G Code line and type in M501 to see what the current settings are for the all of the steps.  They are shown on line M92.  Type in M92 Z***** (where the ***** are the steps you have calculated) then hit enter.  Then type in M500 to save it.  Then type in M501 to confirm the setting change.
  • RAyWB said:
    from your description it´s a TR 10x2 thread  and it will need 1600 steps /mm  at 1/16 microstepping with a 200 steps/rev motor
    Yes, after working through the calculations, 1537.66 works pretty good and is very close to your recommendation of 1600.
  • MartinH said:
    From looking at the kit details  i would say you definitly have 4 start lead screws on the Z axis, so you will
    most likely need 400 steps/mm with a max feedrate of about 30. You should be able to edit these in the eeprom
    via rep host.

    Allso, leave the 3 jumpers installed for 1/16 microstepping
    I will look at these settings to see how it performs
Sign In or Register to comment.