Multiple Printers and connecting to server

edited January 9 in Repetier-Host
Morning,

I have two printers attached to Repeter-server (running on a Pi 3). One printer is a Delta and one a Cartesian so of course I have two different printer profiles.  

To select\change the printer I want to print on in Repetier-Host,  I have to select\change it in two spots 

First I have to select the printer from the dropdown on the main screen and disconnect (if I don't I cant perform the next steps)
image

Open the printer settings
Connect to continue 
Select the printer from the drop down list
then apply. 

image

Am I doing the right? I would think that it should remember these settings so when I select the printer from the front screen it should know\remember what server printer to point to. 


Thanks again


Comments

  • Posts: 67
    Also why do I see two HE3D Delta 180+ in the drop down. I only have one setup on the server ??
  • Posts: 0
    There is no need to apply the printer again in printer settings. You have 2 configs with different server profiles connected. Just connecting with the other profile should be all needed.

    Double entry is current value plus options from server.
  • edited January 9 Posts: 67

    Thanks for the reply.  

    I still get this when I switch printers. 

    The image is what I see when I change printers (it automatically connects)  and slice an object. Unless I disconnect and reconnect the print button is greyed out.  I can "save to server"  and it goes to the correct printer on the server.

    image







  • Posts: 0
    So when connecting to new printer without disconnect that happens? Ok have to test that. Sounds like host does not see the reconnect then and thus hides the button.
  • edited January 9 Posts: 67

    The option to select the printer is greyed out (also in print settings). So I have to disconnect before changing printer. 

    I'm going to muddy the water a but I have been testing further.  It is a enable\disable toggle thing.  Here are the steps to reproduce.

    Here are the steps to reproduce it on my computer.

    • Printer 1
      1. Connect to the first printer
      2. Slice an object with any slicer - Print is greyed out.
      3. Disconnect \ Reconnect - Print function is enabled
    • Printer 2
      1. Disconnect and change to the next printer
      2. Slice the object again - Print function is enabled.
      3. Disconnect\reconnect - Print is greyed out.


  • edited January 9 Posts: 67

    Both printers are online in server. 


    image


  • edited January 9 Posts: 67

    More info.  If NO objects are printing everything works as expected.  To reproduce the issue you must be actively printing on one printer.

    If one printer is printing (and the other is not). BANG the print function is greyed out incorrectly. I think the button state may be swapped with the first printer (or off by printer-1).


  • Posts: 67
    Morning,
    This has been consistent and I suspect a real bug (normally its all me :) ) .  If you agree please move this to the bugs section

    Problem: When Repetier Host is connected to Reptier-server with multiple printers attached. Print function is disabled on the wrong printer when printing to second printer. 

    Here are the complete steps to reproduce.

    • Setup
      1. Setup Repetier Server on Raspberry Pi. 
      2. Configure two or more printers on the Repetier-server and also in Repetier-Host
      3. Start a print on the second printer
      4. Disconnect  

    • Printer 1
      1. Connect to the first printer
      2. Slice an object with any slicer - When slicing is complete , Print is grayed out.
      3. Disconnect \ Reconnect - Print function is enabled
    • Printer 2
      1. Disconnect and select the second printer (Repetier will auto-connect)
      2. Print function is enabled.
      3. Disconnect\reconnect - Print button is grayed out.

    Hope this makes sense 

    Terry
Sign In or Register to comment.