Image for Raspberry PI 3 Repetier server 0.80.1 cannot connect to WLAN

I have 2 routers and not able to connect to both with image 0.80.1. When I am setting up WLAN in Global Settings I am not prompted to enter router password and Repeteir server disconnects. I saw similar post for SSID with spaces for 0.80.0 version, but I do not have spaces in SSID. One router has dash in the name another just characters and numbers.  

Comments

  • Do you have V4 image? Older versions had problems with a bug in network-manager when switching from AP to wlan so it did not see the ssid on connect attempt.
  • I'm experiencing the same issue.  Router name that I'm trying to connect to only has lower and uppercase characters, no spaces.  Is there anything that I might reference to resolve this?
  • Correction, when I click and wait (about 10 seconds) I will be prompted for a password.  However, when I try to connect I'm given an error that says "This installation does not support wifi configuration".  Looking at version comparisons suggests that connecting to WLAN is available in free and pro versions.

    I'm running .80.3 image on raspberry pi 3.  Any advice would be greatly appreciated.  Thank you.
  • WLAN support is available for free but it only works with our sd card image V6. All versions before had issues under some conditions. So please make sure you have exactly that image installed. It has the helper scripts all unter /usr/local/Repetier-Setup and if the file bin/manageWifiAccess is available it will offer wlan settings in server frontend. IN all other cases you have to use the linux functions manually.
  • I have same problem.  Steps:
    1) turn on Rasberry PI3 (of course the latest image i used from repetier site).
    2) connect via phone then go to global config
    3) select WLAN
    4) select my SSID
    5) However, I don't have any chance to enter the SSID password, then my phone loses connection to repetier server.

    After awhile, repetier AP comes back online and I can connect to rasberry PI3 via built-in AP.

    Please let me know what I am doing wrong.

  • If you can connect once with ethernet and then enter password over that interface. This will not disappear. 

    Network disappears as it tries without password and when it sees password is needed connection is already lost and you miss the popup for password I guess.

    I think I need at least one more iteration to make it work even better. In your case it should have connected that no password is known so it should ask directly for a password before even trying to connect. Will check that for next release.
  • I figured out the problem.  From my experience, use the wired connection first then open the browser, type in the wired IP address and under WLAN config, select your SSID then you can see the pop-up.  Now, problem after this was that after awhile, I lose the connectivity Rasberry Pi3 after long period of time. Some ppl says that this is due to 2.4Ghz and 5Ghz or due to the fact that the power management is on by default. 
    (you need to know how to use ssh, know how to get the wired IP for your rasberry Pi3 and default username and password to get into Rasberry Pi3 via ssh [hint: pi/raspberry])

    you can check the wlan0 power management setting by typing:
    sudo iwconfig wlan0
    and you can temporarily disable it by:
    sudo iwconfig wlan0 power off (I think this will reset once you reboot).

    Well, I solved it by the following:

    1. update (is this needed? not sure but update never hurts, IMHO).
    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo rpi-update
    sudo reboot

    2.  make sudo iwconfig wlan0 power off permanent by:
    sudo touch /etc/network/if-up.d/wlan0
    sudo chmod +x /etc/network/if-up.d/wlan0
    sudo nano /etc/network/if-up.d/wlan0
    type the following:
    #!/bin/sh
    /sbin/iwconfig wlan0 power off

    then save by hitting <contro>+x, "y" <enter>, then reboot
    sudo reboot

    after reboot, login via ssh and type sudo iwconfig wlan0, some where should say Power Management: off

    Hope this helps some people.
  • As we need it constantly on I think it is a good idea to do it knowing that it helps at least some. Will add it to the default image for next release.
  • Thanks for taking time to read my post and also taking into consideration of adding it into the next release of the Rasberry Pi3 image.
  • You know what...it happened again.  So now I know what's happening but not sure why...I lost connection yeterday night, I checked the /etc/NetworkManager/system-connections/ folder and there should be a config file for my SSID but now it disappeared.  So seems like it's not a wifi problem per say but the config being wiped out after some event that happens to the Rasberry Pi.  How can I troubleshoot this issue?
  • Our scripts delete these config files if they see the ssid, try to connect and fail. The then assume it is a wrong password. I guess if the connection is not perfect or some timings are bad this might cause some problems. Did not think making a own wlan handling is so hard.

    One temporary solution would be editing
    /usr/local/Repetier-Setup/ManageWifiAccess 
    after you have successfully connected. Comment line155
    # nmcli connection delete "$P1" ifname $WLAN  &> /dev/null
    whcih is the one responsible for the delete. If you see complete connect logic:
      connect)
    prepareConnect
    nmcli connection up "$P1" &> /dev/null
            ret=$?
            if [ $ret == 0 ] ; then
                    echo "OK"
            else
    nmcli connection delete "$P1" ifname $WLAN  &> /dev/null
                    echo "Failed"
            fi
    ;;
    you see it starts the connection and if that fails it removes it. If I do not remove it and it would be invalid I also get into trouble since AP will always switch on/off as it tries to reconnect over and over again. Have to think how to solve both problems the same time. Maybe making a separate delete call and trying several times on networks that worked in past.
  • edited January 2
    Ok, thanks for looking into the problem.  Hopefully, you will have a permanent workaround for this.  I have edited the file but just to let you know the file is in: /usr/local/Repetier-Setup/bin and file is called manageWifiAccess

  • I was pulling my hair out over this one. Same problems. I would try to use the access point from my phone and computer. I would reach the point where I click to select my Wi-Fi network and then the AP would turn off, killing the connection. I never made it to the point where I could enter in my network password. I tried that for a decent amount of time before giving up and plugging it into the network at the router and trying again. 

    I would recommend it not delete the last saved network and password. Maybe wait a few minutes and try again?

    I think I semi-permanently fixed it by renaming the manageWifiAccess file and then hardwiring the SSID and key into the /etc/network/interface file.
  • Soon new version with new wifi management comes. Seems more stable and also permanently stores passwords for networks.
  • Hi all, same problem, it seem that lost password. Solved (at moment) re-writing password in configuration form.
    Other (seem) bug: on lcd, when click on connect, "connecting" message is on window and no more operation are possible, but only by web.
    I'll wait for new version.
  • Since 0.80.1 we have improved password and wlan handling already. Please use the 0.82.3 image.
  • 0.86.2 of course.
Sign In or Register to comment.