Ubuntu 16.04

How do you get Repetierhost to work on Ubuntu 16.04, apparently the latest version of mono doesn't work with it? Please help.

Comments

  • edited November 2016 Posts: 0
    Hey guys,

    I have the same problem:

    unfortunately the software wont start.

    "cappy@computer:/usr/bin$ repetierHost
    cappy@computer:/usr/bin$
    Unhandled Exception:
    System.IO.FileNotFoundException: Could not load file or assembly 'System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.
    File name: 'System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
    [ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly 'System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.
    File name: 'System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
    ^C
    cappy@computer:/usr/bin$ "


    regards

    cappy

  • System.Windows.Forms is the UI library used for the app. So your mono did not install that causing it not to start. Check
    apt-file search System.Windows.Forms.dll

    which package would contain it and install it.
  • Hey the latest few versions of Repetier-host aren't communicating with my marlin printer.  On 14.04 it worked with v1.06, but I suspect that was using a pref from 0.95f.  Basically the 0.95f version let me set the data bits and stop bits, and my printer doesn't seem to negotiate with the new versions.  It says it connected correctly, and I am in the dialout group, and it's definitely the correct usb port.  I'm running a Velleman k8200 with Marlin firmware  (velleman fw v2) and no response from commands going out.

    From ./configureFirst.sh

    Ubuntu 16.04lts

    System: x86_64
    Using 64 bit CuraEngine
    [sudo] password for alewis: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package libmono-winforms2.0-cil is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
      mono-reference-assemblies-2.0 mono-devel

    E: Package 'libmono-winforms2.0-cil' has no installation candidate
    Checking if you are in the dialout group.
    1
    User already in dialout group. Adding not required.
    Compiling helper software to allow non ansi baud rates for some boards
    depending on the used serial driver.
    Configuration finished.
    IMPORTANT: In addition to the bundled CuraEngine, the host also
    supports Slic3r and Skeinforge. These slicers are not bundled, so
    need to install them according to their docs and then set the path
    to them in Repetier-Host.
    For Slic3r simply unpack the tar you get on http://slic3r.org in this directory.
    The host will then register and add it automatically on next restart.

    IMPORTANT: You need a recent mono version since the host uses .NET 4.0
    If you see the following error message, your mono is too old!
    >>> System.Windows.Forms.SplitContainer doesn't implement interface System.ComponentModel.ISupportInitialize <<<
    This folder now contains a Repetier-Host.desktop file
    Copy it to your desktop to get a launch icon there

  • We removed stop bits/data bits/partiy as all firmwares use the same anyway. All that matters is communication protocol (autodetect should work) and correct baud rate. Also make sure no other software is using the same port in parallel. While connecting works communication will fail. I also would advice printing over Repetier-Server even if you use host for preparing. Use the repetier-server connector to connect to server to send prints and control.
  • Ah ok.  I figured it out, I had another service that wanted to use the USB port, corrupting the connection.

    Thanks for the help!
  • Hi,

    meanwhile I got repetierHost running successfully.
    But a few days ago I switched over to Linux Mint and have the same problem.
    I promise, I tried to remember hardly what I did a few moth ago to get it running on Ubuntu, but I couldn't.

    On intallation I get this output:

    Cappy@cappycompi ~/RepetierHost $ sudo sh configureFirst.sh
    System: x86_64
    Using 64 bit CuraEngine
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Paket libmono-winforms2.0-cil ist nicht verfügbar, wird aber von einem anderen Paket
    referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
    wurde oder nur aus einer anderen Quelle verfügbar ist.
    Doch die folgenden Pakete ersetzen es:
      mono-reference-assemblies-2.0 mono-devel

    E: Für Paket »libmono-winforms2.0-cil« existiert kein Installationskandidat.
    Checking if you are in the dialout group.
    1
    User already in dialout group. Adding not required.
    Compiling helper software to allow non ansi baud rates for some boards
    depending on the used serial driver.
    configureFirst.sh: 52: configureFirst.sh: g++: not found
    Configuration finished.
    IMPORTANT: In addition to the bundled CuraEngine, the host also
    supports Slic3r and Skeinforge. These slicers are not bundled, so
    need to install them according to their docs and then set the path
    to them in Repetier-Host.
    For Slic3r simply unpack the tar you get on http://slic3r.org in this directory.
    The host will then register and add it automatically on next restart.

    IMPORTANT: You need a recent mono version since the host uses .NET 4.0
    If you see the following error message, your mono is too old!
    >>> System.Windows.Forms.SplitContainer doesn't implement interface System.ComponentModel.ISupportInitialize <<<
    Unknown media type in type 'all/all'
    Unknown media type in type 'all/allfiles'
    This folder now contains a repetier-RepetierHost.desktop file
    Copy it to your desktop to get a launch icon there

    So I did what you said ... but I did not really understand what to do.
    Repetier said:
    System.Windows.Forms is the UI library used for the app. So your mono did not install that causing it not to start. Check
    apt-file search System.Windows.Forms.dll

    which package would contain it and install it.
    On starting repetierHost I get this message:

    cappy@cappycompi ~/RepetierHost $ repetierHost 
    cappy@cappycompi ~/RepetierHost $ 
    Unhandled Exception:
    System.IO.FileNotFoundException: Could not load file or assembly 'System.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
    File name: 'System.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
      at RepetierHost.view.FormPrinterSettings.comboConnector_SelectedIndexChanged (System.Object sender, System.EventArgs e) <0x413574e0 + 0x00181> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.OnSelectedIndexChanged (System.EventArgs e) <0x4131fca0 + 0x00073> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.SetSelectedIndex (Int32 value, Boolean supressAutoScroll) <0x4131fa50 + 0x00129> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.set_SelectedIndex (Int32 value) <0x4131fa20 + 0x00013> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.load (System.String printername) <0x41354730 + 0x001f1> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.comboPrinter_SelectedIndexChanged (System.Object sender, System.EventArgs e) <0x41356e40 + 0x00083> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.OnSelectedIndexChanged (System.EventArgs e) <0x4131fca0 + 0x00073> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.SetSelectedIndex (Int32 value, Boolean supressAutoScroll) <0x4131fa50 + 0x00129> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.set_SelectedIndex (Int32 value) <0x4131fa20 + 0x00013> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.set_Text (System.String value) <0x4134e0f0 + 0x00127> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.load (System.String printername) <0x41354730 + 0x00057> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.LoadDefaultPrinter () <0x41354430 + 0x00117> in <filename unknown>:0 
      at RepetierHost.Main..ctor () <0x41200840 + 0x011ca> in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) RepetierHost.Main:.ctor ()
      at RepetierHost.Program.Main (System.String[] args) <0x411bc1d0 + 0x00037> in <filename unknown>:0 
    [ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly 'System.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
    File name: 'System.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
      at RepetierHost.view.FormPrinterSettings.comboConnector_SelectedIndexChanged (System.Object sender, System.EventArgs e) <0x413574e0 + 0x00181> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.OnSelectedIndexChanged (System.EventArgs e) <0x4131fca0 + 0x00073> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.SetSelectedIndex (Int32 value, Boolean supressAutoScroll) <0x4131fa50 + 0x00129> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.set_SelectedIndex (Int32 value) <0x4131fa20 + 0x00013> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.load (System.String printername) <0x41354730 + 0x001f1> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.comboPrinter_SelectedIndexChanged (System.Object sender, System.EventArgs e) <0x41356e40 + 0x00083> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.OnSelectedIndexChanged (System.EventArgs e) <0x4131fca0 + 0x00073> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.SetSelectedIndex (Int32 value, Boolean supressAutoScroll) <0x4131fa50 + 0x00129> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.set_SelectedIndex (Int32 value) <0x4131fa20 + 0x00013> in <filename unknown>:0 
      at System.Windows.Forms.ComboBox.set_Text (System.String value) <0x4134e0f0 + 0x00127> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.load (System.String printername) <0x41354730 + 0x00057> in <filename unknown>:0 
      at RepetierHost.view.FormPrinterSettings.LoadDefaultPrinter () <0x41354430 + 0x00117> in <filename unknown>:0 
      at RepetierHost.Main..ctor () <0x41200840 + 0x011ca> in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) RepetierHost.Main:.ctor ()
      at RepetierHost.Program.Main (System.String[] args) <0x411bc1d0 + 0x00037> in <filename unknown>:0 

    Can you help me?
    What so I have to do?

    THX
    Cappy
  • googling says it should be contained in libmono-system-serviceprocess4.0-cil
  • Ok thank you,
    I am in the office at work now, but I am pretty sure, that I already have installed the 4.0-cil !?

    Could this be?
    THX
  • ... YES MAN ... that's it.
    Thank you SO much ...

    Cappy
Sign In or Register to comment.