Install issue on Ubuntu 14.04LTS

Hello.

I've installed Repetier Host v1.6.1 on Ubuntu 14.04LTS.  I've run the configureFirst.sh and it ended with the message about updating/installing Mono.  I've done that and "mono --version" shows that I now have Mono JIT compiler version 4.2.3 installed.  However Repetier Host fails to start.  When I double-click the desktop icon I see a brief distortion of the desktop image, which looks to me like a window failing to load properly, and then nothing.

If I run configureFirst.sh again it gives me the same message about needing to update Mono:

IMPORTANT: You need a recent mono version since the host uses .NET 4.0
If you see the following error message, your mono is too old!
>>> System.Windows.Forms.SplitContainer doesn't implement interface System.ComponentModel.ISupportInitialize <<<
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'

I've also tried updating/installing the most recent OpenGL drivers.

Comments

  • I tried running the command to launch Repetier Host from the command line and it threw this error:

    Unhandled Exception:
    System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
      at System.Windows.Forms.SplitContainer.set_SplitterDistance (Int32 value) <0x40972570 + 0x00253> in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) System.Windows.Forms.SplitContainer:set_SplitterDistance (int)
      at RepetierHost.Main..ctor () <0x4089c840 + 0x014cb> in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) RepetierHost.Main:.ctor ()
      at RepetierHost.Program.Main (System.String[] args) <0x408581d0 + 0x00037> in <filename unknown>:0 
    [ERROR] FATAL UNHANDLED EXCEPTION: System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
      at System.Windows.Forms.SplitContainer.set_SplitterDistance (Int32 value) <0x40972570 + 0x00253> in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) System.Windows.Forms.SplitContainer:set_SplitterDistance (int)
      at RepetierHost.Main..ctor () <0x4089c840 + 0x014cb> in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) RepetierHost.Main:.ctor ()
      at RepetierHost.Program.Main (System.String[] args) <0x408581d0 + 0x00037> in <filename unknown>:0 

  • Check in your home directory .mono/Repetier-Server or so. Rename/delete it and try restarting. The splitte rdistance is in registry which is that folder and I guess first install made a defect entry causing the crash.
  • I don't have a .mono/Repetier-Server folder.  I have .mono/registry/CurrentUser/software/repetier/ and then a few folders under that, all of which are empty.

    I haven't installed Repetier Server, just Repetier Host.
  • I've removed and re-installed Repetier Host and there were a few errors during install:

    The following packages have unmet dependencies:
     libmono-winforms2.0-cil : Depends: libmono-system-runtime2.0-cil (>= 2.4) but it is not going to be installed
                               Depends: libmono-system-web2.0-cil (>= 2.10.3) but it is not going to be installed
     mono-complete : Depends: mono-devel (= 4.2.3.4-0xamarin2) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
  • I've solved the installation issue with unmet dependencies:  I was using the latest Mono from mono-project.com, but once I removed their software source and went with the Mono version from Canonical that fixed the dependencies issue.

    I completely removed Repetier Host and re-installed it with the Mono 3.2.8 that installs via the Ubuntu Software Center and no more unmet dependencies.

    Unfortunately Repetier Host still doesn't run.  When I run the command from the Terminal:

    /usr/bin/mono /home/andr01dm/RepetierHost/RepetierHost.exe -home /home/andr01dm/RepetierHost

    I get the errors:

    Unhandled Exception:
    System.ArgumentOutOfRangeException: Argument is out of range.
      at System.Windows.Forms.SplitContainer.set_SplitterDistance (Int32 value) [0x00000] in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) System.Windows.Forms.SplitContainer:set_SplitterDistance (int)
      at RepetierHost.Main..ctor () [0x00000] in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) RepetierHost.Main:.ctor ()
      at RepetierHost.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 
    [ERROR] FATAL UNHANDLED EXCEPTION: System.ArgumentOutOfRangeException: Argument is out of range.
      at System.Windows.Forms.SplitContainer.set_SplitterDistance (Int32 value) [0x00000] in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) System.Windows.Forms.SplitContainer:set_SplitterDistance (int)
      at RepetierHost.Main..ctor () [0x00000] in <filename unknown>:0 
      at (wrapper remoting-invoke-with-check) RepetierHost.Main:.ctor ()
      at RepetierHost.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 

  • The .mono folder is in your home directory and is hidden.
  • The .mono folder is in your home directory and is hidden.
    Yes, I know.  I'm able to see that folder and it's contents.  There is no Repetier Server folder in there.
  • Here's a tree view of my .mono folder:


    ~/.mono$ tree
    .
    └── registry
        ├── CurrentUser
        │   └── software
        │       └── repetier
        │           ├── 3d
        │           ├── printer
        │           │   └── default
        │           │       └── ext0
        │           └── window
        └── last-btime

    None of the folders contain any files.
  • edited October 2016
    Had a very similar problem on ubuntu 16.04.
    My solution:

    sudo apt-get install mono-complete

    Then 

    sudo sh configureFirst.sh

    will create the Desktop-File
    Copy Desktop-File to Desktop.

    Left mouse click on file  

    Properties -> Rights -> Execute File -> Yes

    (Sorry. Just have the german command words. Do not know how all things are named in a english ubuntu version. But U will manage it )
  • Mine failed to install, any clue how to fix it?

    using Ubuntu-Mint, after installing mono-complete, then:

    mike@MYPC ~/Apps/RepetierHost $ sudo sh configureFirst.sh
    System: x86_64
    Using 64 bit CuraEngine
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    Package libmono-winforms2.0-cil is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
      mono-reference-assemblies-2.0 mono-devel

    E: Package 'libmono-winforms2.0-cil' has no installation candidate
    Checking if you are in the dialout group.
    0
    Adding user root to the dialout group.
    You need to login again in order to connect to your printer.
    Compiling helper software to allow non ansi baud rates for some boards
    depending on the used serial driver.
    configureFirst.sh: 52: configureFirst.sh: g++: not found
    Configuration finished.
    IMPORTANT: In addition to the bundled CuraEngine, the host also
    supports Slic3r and Skeinforge. These slicers are not bundled, so
    need to install them according to their docs and then set the path
    to them in Repetier-Host.
    For Slic3r simply unpack the tar you get on http://slic3r.org in this directory.
    The host will then register and add it automatically on next restart.

    IMPORTANT: You need a recent mono version since the host uses .NET 4.0
    If you see the following error message, your mono is too old!
    >>> System.Windows.Forms.SplitContainer doesn't implement interface System.ComponentModel.ISupportInitialize <<<

Sign In or Register to comment.