Disable sensor decouple test

edited January 2016 in Feature Requests
It would be nice have checkbox in configuration wizard for possibility to completely disable sensor decouple test on heated bed and hotend.

For example my hotbed never reaches more than 115 degrees. And firmware is turning it off at 95 degrees. 

Yes, i know i can just set Decouple test period to insane value. But 1. many useres just want to be sure it is disabled 2. Idk if it does turn it off or there are some related things that has to be turned off.

Thanks and happy new year !

Comments

  • Setting decouple time to 0 should disable the test.
  • Well, the decoupling seems to be a bit problematic.
    I've set the difference to 300, yet it did little difference - as the fan started to blow on the model due to short traces on upper levels, this decreased the temperature of the bed (5mm distance) by 2 degrees right at the spot of the sensor - I have 4 unfinished prints all stopped at more or less the same point :(
    I had to disable the decoupling and will try to print a 5th one now.
  • I tried with decouple time on 0. It takes a bit longer but still, after some time...decoupled. Using 0.92.9.
  • I have the exact same issue, prints failing due to fan reducing heated bed temperature by a few degrees near the start of prints. Very annoying. It would be good to disable decouple check for heated bed only (the bed can't get dangerously hot anyway) while keeping it on for the hotend that does have the ability to get very hot.
  • Each heater has a own timer so that would be no problem.

    Better solution would be to increase allowed swing/time so it is still working just not triggers on fans being enabled.
  • edited October 2016
    I managed to solve this problem. First of all setting decouple time to 0 for heated bed does seem to disable decoupling check. I also checked source code of Repetier firmware and it completely disables decoupling test if decouple time is 0.

    However the real cause of the issue is that the fan is able to cool the printed bed. I have a very good ducted dual-fan setup that works wonders with PLA but is overkill for ABS, so I have done the following:

    1. Setting max fan speed to 70 instead of 100. 
    2. Replaced MOSFET on RAMPS 1.4 with IRLB8743PBF. This has very low on resistance so increases current going to heated bed.
    3. Shortened wires to heated bed (wires also have resistance lowering current reaching the heated bed)

    Now my heated bed takes 7 minutes to go from 25C to 100C (used to take 12-13 mins previously) and I can run the fan at up to 90% speed without dropping bed temperature.
Sign In or Register to comment.