Cura doesn't use settings

I upgraded to RepetierHost 1.5.4 on linux. There seems to be a problem with cura settings. I set extruder temperature to 220°C in the configuration but the produced g code always sets it to 210°C. The travel speed from home to Z15 is also set to F300 (which is very very slow) in the g code, eventhough travel speed and z-travel speed in printer settings are set to 4800mm/min.

I hardcoded the travel speed in the "Start G-Code" section but those settings are not used in final g code.


As far as I could see, the cura settings are stored in ~/.local/share/RepetierHost/cura.ini
I already deleted the directory to make sure no old settings override something, but that didn't solve it.

Are there any other files which store setting?

Comments

  • The values are not stored there. This file is generated from your settings once you hit slice. The real code is in ../RepetierHost/CuraEngine/<printername>/...

    Make sure to save the settings and also to select the same names in the right you edit on the left. Both do not need to be identical!
  • The settings were correct. I had to replace the cura executable with the cura64 executable in the plugins directory. Size of both executables was the same but md5sum differed.
  • Same problem with the temperatures but on Windows 7 Pro 64. Setting 110 degrees for the bed and 225 degrees for extruder. But when i hit print button it always drops temperatures to 50 for bed and 210 for extruder. I have to pause the printing, rise the temperatures and then go on printing. Other setting apply correctly. What should i do to fix this?
  • CuraEngine has no temperature handling. It comes from the start/end gcode we send explicitly to insert. So have a look at that part of the configuration.
  • ; Default start code
    G28 ; Home extruder
    G1 Z15 F{Z_TRAVEL_SPEED}
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    {IF_BED}M190 S{BED}
    ; Activate all used extruder
    {IF_EXT0}M104 T0 S{TEMP0}
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    {IF_EXT0}M109 T0 S{TEMP0}

    Which part of the start code should i edit?
  • {IF_BED}M190 S{BED}
    sets bed temperaturw and uses the temperature from the selected filament. If you have several filaments for multi extruder selects the coldest bed temperature. So check filament bed temperatures or uncomment that line to keep your starting temperature.
  • I'm end up with this code

    ; Default start code
    M220 S40 ; 40mm print speed
    G28 ; Home extruder
    G1 Z15 F{Z_TRAVEL_SPEED}
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    M190 S110 ; Bed Temp
    ; Activate all used extruder
    {IF_EXT0}M104 T0 220S{TEMP0}
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    {IF_EXT0}M109 S220 R230{TEMP0}

    I'm sure it's messy but everything is working. Thank you for help.
  • {IF_EXT0}M104 T0 220S{TEMP0}
    should be
    {IF_EXT0}M104 T0 S{TEMP0}

    and

    M220 S40 ; 40mm print speed

    sets the speed multiplier to 40% of what you say, so it is only 40mm if you have set speed to 100mm/s. This is more for correcting speed while printing not as general speed definition.
  • edited January 2016
    Now i found another problem. Cura does not apply Infill settings. Always print ~5-10%. And there is no Honeycomb option.
  • It uses the infill you select on the right tab where you start CuraEngine (not cura) and yes it does not have a honycomb infill.
  • Correct - CuraEngine. I found the slider. Didn't realise it is responsible for infill. Thank you again.
  • Hello! I have an issue with CuraEngine ignoring my extrusion speed settings; i have all speeds set for 70 (which is apparently the maximum for the printer). It does the solid bottom layer at the full speed, but when it gets to the "hollow" part it slows down to 15-30% speed, even though i have infill and all perimeter speeds set to 70 (it's a small part that i need to make many of, and now takes 30 minutes instead of around 5..).

    Could it be that it has a cooldown time or something? The parts are quite small and i print them "standing up" so the surface area is even smaller. It predicted a faster time when i turned the part on its side, but its shape doesn't support printing like that :-/

    I use Repetier host for Minifactory 1.0.6 and slice with CuraEngine.

    Thank you!
  • Looks like it must be a cooldown thing, when i placed 30 of them on the bed, the time per part went down to a bit over 6 minutes..
Sign In or Register to comment.